Shipping Method not showing up

We have a product defined with a weight of 0.44 lbs.

We have a shipping method (realtime calculated) of USPS First Class Mail The range is 0.00 - 0.60

When you edit it, you can see under Weight Dependencies it has:

more than 0lbs: 0 added money.

more than 0.4lbs add 0.60

When going to calculate shipping when checking out, the system doesn’t show the USPS First Class option. All requirements are met. I don’t understand what the problem is. If I change the product to a weight of 1.0 then Priority Mail shows up (which is defined to display at 1lb to 4.5)

We tried creating localizations and added this to the USA localization and everything and it still doesn’t show it.

Why isn’t this working? I have tried everything to try to figure this out.

We’re running the latest version 2.1.4

Please check if any error is displayed when you test this shipping method in your CS-Cart admin panel.

Open the General tab of the shipping method, enter the desired value into the Weight (lbs) input field and click the Test button next to the Shipping service field to make a test calculation of shipping charges.

In every case, no matter what shipping method I am testing, when I click the the test button with any value in the pounds box I get a blank page. It creates the popup and it simply says “close window”.

That is true for the shipping methods that do calculate properly on the public side and those that do not.

I don’t get an error at all. I viewed the source and there simply is nothing output at all. I have copied the source below.



body,th,td,tt,p,div,span {
color: #000000;
font-family: tahoma, verdana, arial, sans-serif;
font-size: 11px;
body,form,div {
margin-top: 0px;
margin-bottom: 0px;
margin-left: 0px;
margin-right: 0px;
body {
background-color: #fbfbfb;
p {
margin: 6px 0px;
a:link, a:visited, a:active {
color: #296dc1;
text-decoration: none;
a:hover {
color: #f27a00;
text-decoration: underline;
.table {
margin: 0px;
border: 1px solid #a5afb8/*#D0DBE3*/;

.table th {
color: #151515;
font-weight: bold;
text-transform: uppercase;
.table th {
background-color: #c6d5e8/*#d1d9e4/*#b3e3fc*/;
white-space: nowrap;
padding: 7px 8px 6px 8px;
text-align: left;
border-bottom: 1px solid #a3aabe;
.table .table-row {
background-color: #f1f8ff;

Close window


I was wondering if the last time I upgraded it didn't go so well or something. Perhaps a file is missing.

Incidentally, now shipping on the public side can’t be calculated. We get an ajax error that it failed. I don’t know what is wrong with it now. It was working last night. I don’t know if my partner helping me did something behind the scenes to make it fail.

i’m having the same problem. however, i have a feeling it is because i haven’t configured any shipping settings. i haven’t configured any shipping setting because when i click the “Configure” tab for any shipping type it does nothing, as in, it is just a blank page.

  1. i have checked that CURL is enabled and up to date.
  2. shipment processor(s) is enabled
  3. “realtime” shipping box is checked in Rate Calculation
  4. configure tab displays nothing

Yeah, I was going to mention that. When I click on “Configure” there is nothing there, it’s blank.

The problem requires the investigation on your server, so please contact our support team via Customer Help Desk.

As you may have known, I did open a support ticket but I also posted here to see if others knew. The solution was that the files from the previous installation were still there, they were not removed because I didn’t upgrade properly.

When they removed the files and got it upgraded properly everything is working now. Thanks CS-Cart.