SEO on Xampp

Ok, I’ve tried everything I could find to do and still can’t get SEO to work on my localhost.

I really like developing on my localhost as it allows me to test everything before going live with it. The thing that has annoyed me forever is that I can’t get SEO to work.

I have searched these forums and have tried the answers I have found. I have also googled and tried those answers as well. Unfortunately I still can’t get this to work.

It is very frustrating. Does anyone have any ideas on how to make this work?

Thank you,


I’m having the same problem.

despite mod_rewrite being enabled, the SEO addon can not be enabled.

what’s strange is that Apache is reading the htaccess because adding some gibberish like:


will throw a 500 server error as it should.

I’m just on the trial right now until my money gets transferred to my PayPal account, so maybe the SEO just doesn’t work until you are running fully licensed.

I had a hard time with this for a long time and all it was was just not having the .htaccess correct. This is how my .htaccess looks on my localhost:

```php DirectoryIndex index.html index.php

RewriteEngine on

Some hostings require RewriteBase to be uncommented


Your store url is

So “RewriteBase” should be:

RewriteBase /store/cart

RewriteBase /saltwatertogo

RewriteCond %{REQUEST_FILENAME} !.(png|gif|ico|swf|jpe?g|js|css)$

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule . index.php?sef_rewrite=1 [L,QSA]

RewriteCond %{REQUEST_FILENAME} ./catalog/.

RewriteCond %{REQUEST_FILENAME} -d

RewriteCond %{REQUEST_FILENAME}/index.html !-f

RewriteRule . index.php?sef_rewrite=1 [L,QSA]


This is the part that makes the SEO work on my localhost:

RewriteBase /saltwatertogo

Hopefully that will help.


Brandon -

Thanks for posting this. I have the SEF URLs working now, but no joy for the HTML Catalog generation. Were you able to get the HTML Catalog funcitonality to work under Windows XAMPP?




I solved this. I just need to change the “Read-only” setting on the “catalog” directory.