not being called


I am trying to load some .js files from using a file. I’ve placed the tpl in skins/myskin/addons/my_changes/index/ but the file is not being read. What is strange is that I have tried modifying /common_templates/script.tpl and that did not work either. What did did work was adding a hook to the file in main.tpl which I know is not the best way to do this. I’ve had other problems using hooks as well. I’ve been trying to implement this mod with no success – CS-Cart Documentation — CS-Cart 4.16.x documentation

I’ve confirmed that the addon my_changes is turned on and, I was able to get a bottom.override.tpl to work.

I’m 1 week old into CSCart so I figure there is something I am missing. Any suggestions on what that might be is appreciated.


My bet is that you did not clear the cache after uploading your file. Since pages are cached, it needs to be cleared to read the new data (even when store is in development mode).

An alternative bet is that while you state where the file is located in your message, you really have it in the wrong place. Check what skin you are using via Design/Skin selector for the customer area and ensure that 'myskin' above reflects that skin name.

Hooks have worked without issue for a long, long time. In 99.9% of the cases I've looked at, hook problems are related to the developer, not the cart architecture. The other 0.1% of the time it is a problem of priority and other addons using an override which wipes out lower priority overrides.

Thanks, I knew it was me, just did not know what to look at. Clearing the browser cache was not working but adding “&cc” to the end of an admin url did. Still trying to understand the inner workings.