RSS Addon Creating MySQL Error in 3.0.6

We recently decided to start automating a subsection of our marketing emails and decided to try and leverage the RSS addon and noticed that it might be in conflict with another addon and/or scripts in our custom theme. What we're noticing is that when the RSS addon has the selector for adding a feed to each category enabled, we see the MySQL error in the attached screenshot. Regardless if this option is selected or not, the global RSS feed works as expected but the feed fails for categories.

There are no custom modifications outside of the skin. The only custom addons we're currently running is a module we had developed that pulls a SoundCloud player into the UI. The player is available in both the category as well as the product pages. This shouldn't reasonably be in conflict with any of the other moving parts inside the framework, but the fact that it cannot dynamically produce an RSS feed by category is of great concern.

Any and all suggestions or feedback are welcome.

And seeing as how the “attach” function didn't work, here's a link to the screenshot -

Thanks in advance.


where is the screenshot? It could be a write permission problem.

Hi VPS Node,

Th screen shot was in my reply to the thread. Here's the link again in case it isn't obvious -

I do need to resolve this fairly quickly, so any assistance is much appreciated.

Edit: Here too is a screenshot of the backtrace -

Given the files being referenced, I don't think it's a permissions error and after debugging for an hour or so there also doesn't appear to be any errors with the dynamic scripts.

please check if you have column [color=#ff0000]updated_timestamp[/color] on table [color=#ff0000]cscart_products[/color] becouse is missing

...ORDER BY products.updated_timestamp desc...


Hey Valentin,

There is no table for updated_timestamp, just timestamp. I've gone through several of the core files that relate directly to products and categories, but not one of them looks at that table except for the RSS addon.



it looks like the RSS Addon can't create the column in the database.

It's a rubbish plugin anyway, on my site a lot of the category RSS links don't show anything at all. And the is no default RSS to show all products on the site.

VPS Node: We thought of that as well, but after uninstalling and then reinstalling the addon the feed throws the same error as to what's in the screenshot. Another piece that's been regressed is a fresh install of 3.0.6 and the same error occurs because no column called products.updated_timestamp is inserted into the database. It seems as though the RSS addon is what should have created the column on install, but that's not at all what's happening.

kickoff3pm: We have the global feed working just fine which is what makes the errors in the category feed so odd. Is your suggestion then that we abandon the CS Cart addon and instead work with a third party solution? Of all the third party stuff we've looked at there are a couple of dev houses that we've already had abysmal experiences with, so this isn't really something we're too keen on…

Our overall goal here is to automate our marketing emails via MailChimp by alerting customers who habitually shop in certain categories that new products are available. The best way to accomplish this is to make sure MailChimp is receiving the RSS/Atom feed by category. We're a small company, so every bit of automation we can accomplish is in our best interest because we're obviously a little too “in the weeds” to be effectively communicating with our customers on a regular basis.

If I were to manually insert the column for products.updated_timestamp, does anyone know what schema I should apply to it. Do we know if on save of a new product that the timestamp will store in the right place? Will I also be looking to make core modifications in order to get this to go?

What url are you using for the default feed ? I can't find it.

I've asked a developer to produce an addon, I'm in no hurry for it but he might be able to help you.

I like the idea but don't know much about mailchimp, will these people not sign up to your newsletters. Alternatively perhaps you could create a meber group for each category and then auto send new items to the groups each month etc.

Hi kickoff3pm,

Here is the URL that's automatically generated by the RSS addon - This is the URL for the global feed that is functioning, and it's the category feeds that are breaking down. I also just ran a test in my sandbox by creating a new product and seeing if it was added to the global feed. It indeed is, but the category feed still throws the error in question.

As to your suggestion of user groups and leveraging the newsletter feature, the alternative is indeed a great idea but it wholly defeats what we're after. We'll be missing out on a very large section of metrics and hence why we're using a platform like MailChimp for our email marketing. There's no effective means of tracking the actual impact of a CS Cart generated newsletter (i.e. bounces, forwards, social sharing, click by item, FB like, etc…), and again why we're using a third party.

Folks who will ultimately receive the emails have indeed signed up for our newsletter, but the point here is being able to target our audience with effective communications that are attenuated to their buying history. Going back to the conversation of automation, we are a small company and cannot afford the resources it would take to monitor customer purchases and then add them to pre-defined groups. Segmentation like this in MailChimp takes seconds instead of hours and days.



Just a thought about this updated_timestamp, I just checked mine and the table is there. But only few have data.

I don't know, I'm no expert, just wonder if you have added your products via csv import like I have. If so I wonder if we put data in these field perhaps the category will work. I've got a test system so I'm going do that now to see what happens.

Well that didn't work, bloody anoying subcategories seem to work but if a category has a subcategory the top category doesn't.

kickoff3pm: We were previously running on CS Cart v.2.1.4 and went live with 3.0.3 in March after roughly 7 or 8 months in development. We initially used the Store Import feature in 3.0.3 to bring all of our data over but the feature ended up not working as advertised, so we had the CS Cart support crew port and upgrade our data. Everything has gone swimmingly with the exception of this piece.

What's sad is that the updated_timestamp column is not inserted into the database with a clean install of 3.0.x. We've tried this a couple of times and still have no results. Suffice to say there's an “insert” command that's missing either from the CS cart installation script or the addon's. And to repeat a point from earlier, it's confusing why the global feed works while categories doesn't. If you look at the XML in the link posted above, several of the products listed in the feed show the correct creation date (we added a few products last week and those are the ones at the top of the feed).

As for the CSV import, it can't really be trusted as it will skip or arbitrarily lose data. The feature isn't capable of merging rows, so it's not something that's going to be too terribly helpful to us at this point. Even if we were able to produce a CSV with the update_timestamp column, we already know it doesn't exist in our iteration so that's a piece that will be dropped on import since there's no place to put it and no schema to apply. Great thought though.

Anyone else? We're all doing a great job of pointing out the issues, but I unfortunately need to start talking actively about solutions.


After confirming that the updated_timestamp column wasn't included in the initial database install, I managed to find the schema and manually insert the column into the database. I sadly found the schema in CS Cart 2.2.5 and 3.0.3, but not in any other version I currently have on hand.

It looks like some CS Cart installs will actually skip certain parameters outlined in the schema.sql file found in the install directory. Even though the RSS addon is active by default on install, most users will probably never see this error unless they enable the category feed like we did.

Here is the query for those who might be experiencing the same issue -

ALTER TABLE cscart_products ADD updated_timestamp int(11) unsigned NOT NULL DEFAULT '0' AFTER timestamp

Thanks very much for all of the replies.