RMA Addon Bug?

I Upgraded 2.0.10 to 2.0.11 last month. I tried to activated “RMA” Addon under administration → addon and followed knowledge base v2.0 - Setting up the ‘RMA’ addon, but I can’t find “Return requests link” under Orders tab , No “Allow return registration” check box inside the Order statuses, and No “RMA section” under addon tab of catalog–>product.

Are there something wrong with 2.0.11 or my upgrade?

Fixed the problem! Just uninstalled RMA Addon and reinstall it again…that is it!

I’m having the same problem with 2.0.12.

I tried uninstalling the RMA addon and re-installing it but still no-worky… also, now the “Return Request”, “RMA reasons” & “RMA actions” Tabs of [Orders] > [Return requests] show “page Not Found” ERROR !



The Un-Install process removed all files & rma folders from

skins/basic/admin/addons/rma and skins/myskin/customer/addons/rma.

I have re-uploaded these files and restored the rma addon.

Unfortunately, however the original problem remains.

This is a BUG !??

What status is the order? Assuming it is ‘Completed’, check the ‘Completed’ order status to make sure that “Allow return registration” is checked. Also, check to make sure that the order contains at least one item that is within the return period.


My rma is doing the same thing. I am running 2.12 and I have installed and reinstalled the rma. It doesnt matter what status i put the orders in the return tab does not show up on the account page.

See this post: