Renaming Admin.php Problem


[color=#555555]I changed admin.php to admin8551.php through config-local and renamed the admin file accordingly. Then cleared the cache., Now when I try to edit store name [/color]http://www /admin8551.php?dispatch=companies.update&company_id=1[color=#555555] and click save I get page not found ([/color][url=“”][/url][color=#555555])[/color]


We were unable to find what you were looking for.

The page you have requested cannot be found.

Error code: Page Not Found

[color=#555555]I also cleared the var/cache folder manually through the ftp program and clear browser cache but the same problem occurs. [/color]

[color=#555555]Any help would be appreciated. [/color]



edit config.local.php

// Names of index files for the frontend and backend

$config['customer_index'] = 'index.php';

[size=4]$config['admin_index'] = 'admin8551.php';[/size]


I did that already…here is a copy/paste from my [color=#282828][font=arial, verdana, tahoma, sans-serif]config.local.php[/font][/color]

// Names of index files for the frontend and backend

$config['customer_index'] = 'index.php';

$config['admin_index'] = 'admin8551.php';

There are 3 steps to this process.[list=1]

[]move admin.php to the new filename

]change config.local.php $config['admin_index'] value

[*]Flush your template cache and registry cache (&cc&ctpl)


My opinion is that they should have done things a bit different with cache clearing.

&cc should clear all caches (templates, thumbnails, registry, etc.)

&ctpl should clear template cache only (but including css and js caches)

&ct clear thumbnails

&creg (new) clear registry

As they have it now, css/js gets cleared with registry (not template). Makes no sense and there's no way to just clear the registry.


Tried all the cache clearing methods from the admin panel as below:[color=#282828][font=arial, verdana, tahoma, sans-serif]cc[/font][/color][color=#282828][font=arial, verdana, tahoma, sans-serif]ctpl[/font][/color][color=#282828][font=arial, verdana, tahoma, sans-serif]creg[/font][/color]

still getting the error page…

any other suggestions?


What is the address in the address bar when the error is generated?

Does that file exist (double check) and have appropriate ownersihp/permissions?

The address is and 403.shtml doesn't exist on my server.

I did all the file/folder permissions using SSH

support says: [color=#444444][font=Verdana][size=3]Please check whether the correct permissions (644) is set up for the [/size][/font][/color]admin8551.php [color=#444444][font=Verdana][size=3]file of your CS-Cart installation. If so, this problem requires examination on your server.[/size][/font][/color]

[font=Verdana][color=#444444][size=3]permission is 644. So I am curious about the server requirements related to this issue.[/size][/color][/font]

Just a thought. I tried a million times and 404 everytime then I thought I would

try a new admin name WITHOUT characters ( only letters and numerals

and BINGO !!