Registry: Undefined Cache Level

[color=#000000]I was just editing my theme today and suddently i could no longer access the storefront.[/color]

[color=#000000]I’m getting this[/color]

[color=#000000]Registry: undefined cache level[/color]

[color=#000000]I can access th admin just fine. I searched google and found nothing about this error[/color]


[color=#000000]I’m using 4.0.3[/color]

[color=#000000]same here. v4.0.3[/color]

[color=#000000]Registry: undefined cache level[/color]

i think is cs cart problem. because my localhost also have same problem.

[color=#000000]Registry: undefined cache level[/color]

same problem here now :S

the weird thing is that it happened right after new year at 12am (my time)

same here, and the site was down too :(

We were doing nothing and the same error is showing right now also

maybe there is a hidden script to connect to and is down currently and we got this error :(

and CS cart support are on holiday until 3rd Jan

Yes , for us also it happened at struck of the new year bell

Maybe it is New Year Present for Licensed Customer !!!

Happy New Year from CS Cart

why why and why :( anyone in Russia or US can call their support right now

They have a US no.

please provide so that we could call

But very likely its just a Front office with none from actual CS Cart team to handle this

Worst New Year ever

I have the same problem. Site down since morning with same error “Registry: undefined cache level”.

Any one found solution?

We have having same issue. This just happened right now. Has anyone found a solution to this Registry: undefined cache level issue? Please help!!

I am having the exact same problem. I had contacted hosting support team on my site and they said they couldn’t see an error from their end. Hm :(

Same here, all my CS-Cart sites show this error since 2014. The Admin works fine, just all sites only show “Registry: undefined cache level”. Tried setting all cache and template cache wtih “cc” and “ctpl” HTTP GET commands, but still the same.

I had a same problem…

I deleted following codes and now it works properly as long as I checked.

if (empty(self::$_cache_levels[$id])) {
die('Registry: undefined cache level');


app > Typh > Registry.php

I don't know this change causes an other issue. I did this because I don't want to keep my shop and my clients' shops closing like this for several days…

At least, stores are now accessible.

My site is working now after I went into appearance and realized I had the time zone set to Russia default still and changed it. o.O

I have the timezone set to Bucharest and I have the same error? Anyone at support can came with a fix?

LE: I changed the timezone to … random… and it works!!!

Litany, G-d bless you.