Quantity step

Seems that the Quantity step in storefront is not working. In the product admin I have a Minimum order quantity of 6 and a Quantity step of 6. When, in storefront, I enter the amount 10, the site let me buy this, no problem.

It should warn me that I can only buy in multiples of 6, correct?

This is working properly for me whether the minimum quantity is set to 0 or 2. The dropdown is stepping by 2 from 2 to 50 units.


I’m not using the dropdown stepping (is that feature called “List quantity count” in admin?). I have a form field where I can enter numbers freely. Could you try this?

Maybe I’m wrong but it seems that the Quantity step is only usefull when having a dropdown list. Shouldn’t it be working when having a free field too?

When I enter a any number into the “Quantity step”, the front-end quantity changes from a form field to a dropdown menu. Have you modified this in your cart?

To answer your question regarding “List quantity count”, this field limits the number of items in the dropdown. For instance, if you have a “Quatity step” of 2 and a “List quantity count” of 3, the dropdown will contain 2,4,6.


That’s weird, I don’t have a drop down showing in the storefront when I fill Quantity step. I thought “List quantity count” would result to this.

99% of my products have Quantity step filled. Could you try and change one of your products by deleting “List quantity count”? Thanks.

I have the dropdown regardless of the value in “List quanity count”. The only difference is that I can use “List quantiy count” to limit the number of items in the dropdown.

What version of CS-Cart are you using?


I’m on CS-Cart 2.0.4 with this particular webshop (I’ve added a signature). There must be another option that changes the form field into a drop down…

I retested this again. My results were consistent: If the “Quantity step” is 0, I have a form field but if “Quanity step” is non-zero, the form field changes to a dropdown.

I also reviewed the Settings in the admin but I did not find anything that suggested it would change display of this field.

It is a little far-fetched, but maybe clearing the cache would fix this. If not, I am out of ideas.