products not showing up in admin

Funny problem since upgrade from 2.0.14 to 2.1

if i go catelog/products it shows the first 10 of my 8000 products.

if i click on one 1 get a blank page .

here are last 2 error logs, one on first page (of products) and second on page 8

[COLOR=“DarkRed”] [Mon Sep 06 12:18:14 2010] [error] [client] PHP Fatal error: Out of memory (allocated 31457280) (tried to allocate 2621441 bytes) in /home/sites/ on line 158, referer: [url]Loading... [Mon Sep 06 12:18:28 2010] [error] [client] PHP Fatal error: Out of memory (allocated 31719424) (tried to allocate 16 bytes) in /home/sites/ on line 3436, referer: [url]Loading...

What i dont understand that if i do a search and have 50 items and then click a link all is well and i see the product page. Ive tried 4000 items and it still shows the product page. best i could do after that was 7000 hits but it didnt like it and i had a blank page.

Any clues. i can work round it at the moment but am considering a fresh install of 2.1 as my site could do with a overhaul.

Not sure if it’s all related, I just posted this: [url][/url]