Product Import - Image Issues

I have scoured the forums and the internet about this issue and haven’t found ANYTHING that has worked yet.

I have all of my product images uploaded (FTP) to images/backup. I have a huge Product CSV file that has a column named “Detailed image” and is filled with “images/backup/[file_name].jpg”. This import works just fine BUT doesn’t show any of the images.

I also created an Images CSV file that just has the Product Code, Pair Type (M), and Detailed image path (same as before) and tried to import it into the Image Import section. Everything worked without errors, but the images still don’t show up.

WHAT AM I DOING WRONG? Thanks for any help!

Maybe the folder needs the right permissions?

Try using the full path.



Thank you for the message.

Like The Tool suggested, you should use the full path to the image on your server. Alternatively, you can specify only file names in the Detailed image field and use the Images directory field in the Import options section below to set the path to the proper directory on your server.

I hope this will help you.

I tried the full directory path in the CSV file and then once again with just the filename in the CSV file and the full path in the Import Settings. Neither is working.

If it is a folder permissions issue, what should they be (and on what folders)?

I really appreciate your help as this is getting really frustrating…

You can check here

[url=“CS-Cart Documentation — CS-Cart 4.15.x documentation”]CS-Cart Documentation — CS-Cart 4.15.x documentation

I tried all not working again…

are all the extensions case the same, if it is .JPG versus .jpg

and if you copy and paste the filepath to a browser window does it take you to the image (obviously by adding http://www. etc etc etc

and why have you got [ ] in there

I tried:

full path

backup directory

exim directory


the same issue…

give us path to an image thats causing grief

When we were having this problem, it's because the required GD php libraries weren't installed on the host server, so it wasn't generating thumbnails. I had to add it on and recompile Apache, then images started appearing normally. The way this looked from the Admin screen was if I went to a product, it showed either a no-image icon or a blank white box, but if I clicked on it, it would display the detailed large picture.