Product import help needed please

I’ll probably have to put in a help ticket for this, but maybe some of you out there have found the trick.

I followed the directions, it seems to work, I get the “Congradulations it worked message”, the products and categories show up in the admin panel, but nothing shows up in the customer screens.

I even go through the products I imported and double check all the information and make sure they are associated with the categories etc., but nothing shows up under the categories on the customer screen. Does anyone have any ideas? Help please! Thanks,


ps: Why does the person’s first name show up twice when they do a review? Ie: say John Doe who created an account enters a product review, it shows up as being done by John John instead of John Doe or his user name. Thanks.

EDIT yes, the available check box is checked. Forgot to add that before

Are your products set “available” has to be checked…

maybe on import you didnt set this…

yup, avail check box is checked… see EDIT above :slight_smile: Thanks,


care to provide a url?

Well, for playing around purposes and not a real solution yet, I have found that if I go back to the admin panel after the import, uncheck the “available” box, update and then re-check the “available” box the product shows up. Go figure eh?

I can’t provide a url b/c it’s on my local testing server. Thanks though.


Another option is to run a sql command against the table and manually set all products ‘available’ = yes


I don’t think it’s really an “available” or not available issue… The imported products are not showing up in their categories. Checking and un-checking the available box makes them show up as products, but they are still not associated with their categories. Odd… something to ponder.


Here is the message from the support desk, I think adding the line to .httaccess is what actually worked. I did a full reboot, not just restarting the apache server and it seems to be working now. Hope if anyone else is having problems this mght help.

“Another guess - there is “register_globals” PHP setting enabled on your server and there is “pid” server variable that is mixed up with one of CS-Cart.

Could you check if the PHP setting is enabled. If yes, disable it or edit .htaccess file located in the CS-Cart root directory. Open the file and add the following line:

php_flag register_globals off”

<—happier now