Product Images Not Uploading

Hi all,

I have added this as a reply to an old post as there is someone with exactly the same issue, but unfortunately it doesn’t appear to be permissions.

So - I just installed a new CS-Cart install (I’ve installed a few now :-))and it seems to be working fine, but product images refuse to upload. I am not getting an error message…after selecting a local image file then saving the product, nothing appears on the product page but I can see the image in the proiduct directory. I can view the image through the file viewer as well!

I ran this test and checked that allow_url_fopen = On in php.ini:


Full permission on images/ and every directory beneath - I’m running Windows 7 and have given “Everyone” full permissions and set it to inherit.

I have tried it under IIS and Apache - same result - IE 8, Firefox 37, Chrome - all the same

I am now at the stage of pulling my hair out!

I can see the images getting into the correct detail folders (detailed/1 in my case) and I can view them using the fileviewer, and when I edit the product, although I can’t see the image, if I hover over the image placeholder, I can see that it is a link to the image, and if I click it the image opens in a new window…it just will not display!

The references seem to be getting into the images and images_links tables in the database as well…

However, when I look at the item under Products in the front end, there isn’t a file there. No link, looking at the source it isn’t there…

Totally bizzarre

I’m beginning to suspect I haven’t configured PHP correctly somewhere as I have just done a fresh cs cart install on this server and have the same issue… but now I’m doubting that as I have created a quick html file to display one of the images I’m trying to upload, and then a .php file to open it and it opens and displays fine.

I’ve also tried images that I use on another CS Cart install that I know work (as they’re live on the server) and they have the same issue

I’m stumped!!

Any help would be gratefully received!

We are also unable to import images in MV 4.2.4. I've read through so many forum posts & help files and tried everything but nothing works as above. I'm also going crazy trying to figure it out. Were you able to identify the problem?!?

[color=#282828][font=arial, verdana, tahoma, sans-serif]When we were having this problem, it was because the required GD php libraries weren't installed on the host server, so it wasn't generating thumbnails. I had to add it on and recompile Apache, then images started appearing normally. The way this looked from the Admin screen was if I went to a product, it showed either a no-image icon or a blank white box, but if I clicked on it, it would display the detailed large picture. [/font][/color]

One problem I hit - the images was there for detail image and all the paths where being created but the smaller images like thumbnails were not being created. The problem was in the GD version. BUT - this would only apply to you if you are using PNG file format for the thumnails. It seems the default GD on some installs does not support PNG.

You can see if this is the case with you by simply changing the file format option in thumbnail setting admin. Once done just open the category or product page the the thumb will be created as normal.