Product export not working


I am on version 2.0.14

When I try to export all products (about 2,500) the page keeps exporting and then stops without any download. When I check the exported file on the server (var/exim) it is an incomplete file.

This problem has been recent. It worked fine until a month back but lately I have never been able to export one complete file.

Please help and advice what may be causing this suddenly and what can I do to make it work again


My browser did this once, I changed to IE and it worked but then when I went back to FF it worked again there so dunno

a one off thing?


Check your PHP and Apache error logs. You might find that you are getting a “Server configuration error” from Apache that you’re not seeing in your browser (in my case, runs for about 5 minutes wall-clock and then generates the error). Long running operations such as a file export can make Apache think that the PHP process has gone away because it’s not sending any data.

Unfortunately, there are a ton of timeout values that can be set in Apache. I have not been able to find the right one(s) to address the problem. You might try figuring out how to run it from Cron which will eliminate Apache from the equation if you find that Apache is the problem.

If there are any Apache guru’s out there, I’d be very interested in a private discussion… Please PM me and I’ll summarize any problem/solution that is a result.