Problem with placing block

I added a block using the product_filter feature to the ‘Homepage’. When making using of this filter, an other page opens with the filter results. How can I have in this next page a different product_filter that does not show up on the ‘Homepage’? Since this next page is not a ‘Categories’, ‘Products’ etc. , the only option left seems to be the ‘All pages’. However this doesn’t work, because it show on the ‘Homepage’ as well. How to work around this?

You will have to add the block via the blick manager rather than using the product filter on the product details page. You can then configure the block to use whatever filters you’ve defined.