Prevent the WYSIWYG editors from doing a <p>

Well, the WYSIWYG editors are kind of a pain in the neck for me. Personally, I was hoping that CS-Cart was going to give you the option to turn on and off the WYSIWYG editors on a product/category level and not just the whole cart.



If you turn off the editors, the are just off for everything.



If they are on, you can use the html part, but that tosses in a

at the start and a

at the end. I don't want that additional code. If I enter in my html, all I want is my html, not the editor's.



So, if I'm going to use the editors, how can I prevent them from adding in the extra code?



Thanks,



Brandon

[quote name='brandonvd' timestamp='1315541809' post='121295']

If I enter in my html, all I want is my html, not the editor's.

[/quote]

I google “CKeditor ad the

tag” and I found some links, but you could find more. There are plenty of user of this editor, and they share tricks.



here is one: Turn off enclosing

tags in CKEditor 3.0



But really, any html should be inside tags so it is proper formatted by the browser. Otherwise how will the browser know what color, font, margin or pads assign to that line of text?. To avoid the

tag you could enclose the text with

and insert
for line breaks.

We need to bypass these wysiwyg editors altogether. Has anyone figured out how yet?

Settings->Appearance…Under Administrator settings: Default wysiwyg editor - Do not use

[quote name='The Tool' timestamp='1317231963' post='122507']

Settings->Appearance…Under Administrator settings: Default wysiwyg editor - Do not use

[/quote]

Right. I guess I need to upgrade to 2.2.2, then.