Pci Scan Fail Do To Php Outdated

Currently site is running cs-cart ver 2.1.1 with php 5.3.x on a manged VPS. Will this version of cs car run on a new version of PHP and if so what version should I ask our hosting provider to set up?



You will need to make changes, otherwise your going to get a lot of warnings and a very full error_log file. Just suppressing warnings will leave performance issues. It’s a tedious job, but it is possible.

We have several builds of 2.0x & 3.0x running now on PHP 5.3. It's a lot of work .. but we have clients who absolutely cannot upgrade to 5.5+ because of other business-critical applications they have running.

But 5.3 will be EOL soon too (if not already). The point of PCI is to ensure that all components are maintained for security patches. Why not just run multiple instances of PHP on a site by site basis on the same server(s)?

Get PCI on vps is a f hard job, trust me

Its not just about click and click you must chose good linux distro and be f good in that

Otherwise you will need do that with your vps provider :-) that was reason why I finished with mine

Now I am on amazon hosting and I am very happy btw is half of price vps :-)

I have got 4.3.6 now and I am PCI too

5.3 was EOL some time ago and PCI compliance is not difficult if you maintain a good security model, use package management and overlay something like WHM to monitor and assist in updating things nightly for you.

Then it's just about shutting down a lot of unneeded services.

You really cannot do this on a VPS that is being used for shared hosting without a lot of work. You have to basically force all of your users to use SSH/SFTP and secure mail connections.