No cookies planted, can't login or use cart.

I have spent 3 days now trying to figure out what’s wrong with my CS Cart installation and still nothing.



Basically, it works but users or admin can’t login and cart is not saved. I found out that the cause of this is the absence of cookies - CS Cart doesn’t set cookies, at all. I tried Firefox, Chrome and Opera under Windows and Ubuntu. All set to accept cookies but CS Cart just doesn’t seem to generate them in the first place.



The weird thing is that is DOES work on iPad! iPad’s Safari lets me login into admin panel just fine. This is can’t explain.



And here’s how the site is set up: in Windows, I run Ubuntu in virtual machine. In this Ubuntu, I’ve set up apache with php5 and that’s where the site is. VM is connected to internet via NAT. To access the site, I use site:38152 because port 38152 is forwarded into VM’s port 80. It sounds complicated but it works, at least site is accessible from outside. I do it this way because at this stage I need to customize skin and be able to make snapshots of work in progress.



Also, it seems like it just broke out of the blue. When I first set it up, everything worked and I was customizing the skin, and then in two days it just broke. I think it was after I restarted VM but I couldn’t get it working ever since, even when I reverted back to a working VM snapshot.



I just don’t know where to look anymore. It doesn’t make any sense.

Is your site an IP or a domain address? If it is an IP with no domain then Chrome and Opera will not store cookies for it. Not sure why Firefox isn’t working but it sounds like it is most likely a configuration error or some issue with running the site through a forwarded port. Does Safari or IE store cookies (on the Windows versions)?

When I installed it, I specified site:port type of address, so it is tied to a domain name with port. I use No-IP to bind my IP to a domain name.



IE8 doesn’t load the site at all, just keeps “Connecting…” and that’s it, all the while other browsers load it fine. Classic IE! But maybe this is symptomatic of something else?



What part of configuration could be responsible for this?

Well, I moved it into a subdirectory of my personal site and it seems to work fine now. Hope it won’t break in two days!