No Backordering

Hi All

I’m sure I’m missing something obvious as usual. I want to prevent customers from back ordering. So for example, if there are only 64 pieces in stock and a customer orders 100 I want them to be only able to order 64 and a message to appear saying on 64 in stock…

Any help appreciated.



Dear Toby,

Open the “Settings” page of your CS-Cart admin panel and make sure that the “Enable inventory tracking” setting is enabled and the “Allow negative amount in inventory” setting is disabled. Then check your product details pages in the admin panel, the “track without options” or “track with options” variants should be selected in the “Inventory” option for them (not the “do not track” one).

Then is should work as you need.

orangegirl is correct, however if your cart version is older like mine, customer places order, order payment fails, he goes to orders page, tries to pay order again, now even product is with negative stock, cart would still allow to pay this order… Each attempt to pay order would decrease product inventory.

Personally I got status “open” not decreasing product inventory only “processed” does this.

Hi orangegirl

Thanks for your reply. Those are the settings I have but it still allows back ordering. Doesn’t really make sense.

Dear hallwoodt,

I am sorry to hear that. This requires the investigation on your server. Please contact our support team via Customer Help Desk.

Is this supposed to be part of the functionality or is it a bug?

Hello hallwoodt!

We cannot call it a bug until the problem is reproduced in standard CS-Cart installation. The problem requires the investigation on your server as I already mentioned.

Kate, please post what you find (problem with merchant’s server, setup issue or problem in the code).