new option combination image not saving

Hi All,

I added a new option combination to an existing combination list for a product but the images aren’t saving after clicking update. The option is there but the images aren’t. I even tried Rebuild Combinations but the images still aren’t saving. I tried it on a couple of products with same results. Any ideas?



Hello, Brenda!

Please try increasing the “memory_limit” and “post_max_size” settings values in your server PHP configuration.

Where do I find the server PHP configuration?

The PHP server configuration can be changed in the “php.ini” file, but it is not allowed to edit it on some servers, so you should better contact your server administrator about this.

I did find the php.ini file but didn’t find the two options to change.

You can add the following lines to this file:

memory_limit = 256M
post_max_size = 32M

After that click on the “PHP information” link at the bottom of your CS-Cart admin panel and search for the mentioned parameters. Check whether the values are the same you entered in the “php.ini” file. If not, contact your server administrator.

I did find the memory section & changed it, but it’s entered as such:

@ini_set(‘memory_limit’, ‘256M’);

So how do I add the post max size? with teh @ini_set as well?


the line of the code you mentioned is not in the “php.ini” file. You can put the similar string for the “post_max_size” setting, but on some servers such directives just do not work. You should better contact your server administrator.

Ok this change has been made but I’m still having the same problem.

PHP max_file_uploads might still have the default value of 20 and that can cause this problem.

Your host must change that setting because it cannot be overridden by the user.

My hosting company changed the max_file_upload to 80 for me & the memory limit to 1024M. neither change solved my problem.

Found the problem/solution. This is what my hosting company said/did:

“It appears the server php.ini file was superceding your public_html php.ini file. I’ve updated the .htaccess file in your web root directory to force your php.ini file to be used”