Local install - can't login to admin

Hi All,

This time, it just doesn't want to work.

Ran a local install of 3.06 MVE on a MAMP setup. Now I have the customer facing site working, but the admin page just redirects back to itself when I login with the supplied credentials (admin email address, pword admin).

I've tried different browsers, clearing cache and even importing my production DB over the local install (and logging in with my normal production login).

Where would I even see any errors generated? All I've got in the apache log is a very boring missing favicon:

[Tue Apr 23 10:20:08 2013] [error] [client] File does not exist: /Users/username/repos/favicon.ico, referer:…n_url=admin.php

Funny thing is… favicon.ico does exist in the shop dir…

I have created MAMP/htdocs as a symlink to my git repo, of which shop is a sub dir… perhaps that is causing a problem?

Any tips?

Ok, Solved… but I would really like to know why.

As per [SOLVED] Fresh Install. Unable to Log into Admin - Installation & Upgrade - CS-Cart Community Forums

CS-Cart just won't work using an alias of localhost it seems. I was using companyname.local:8888 in the config.local.php and also to access via the browser…

When I use localhost:8888, all is fine.