Local development site shows homepage but not product pages

Hello Everyone,



I want to upgrade our 2.0.14 website to 2.1.1. I’m uncomfortable upgrading the live site so I want to resolve all the issues on a test version of the site first.



I tried doing this by cloning our live site to a separate online server and ran into lots of problems. Instead I decided to try copying over the files from our live site to my local computer and I’m using XAMPP as described in their “How to install CS-Cart on a local computer” PDF. After struggling with a few issues I have successfully gotten the homepage to display correctly at localhost/cscart and the entire administrator side of the site seems like it’s working fine too.



The problem is that when I try to go to a category or product page on the local site I get the following error:

[SIZE=“1”]Object not found!

The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

If you think this is a server error, please contact the webmaster.

Error 404

localhost

Tue Nov 9 14:29:01 2010

Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1 mod_perl/2.0.4 Perl/v5.10.1[/SIZE]



I can view the product pages in the administrator so i don’t think it’s a database connection problem. The address/path to the product pages is the same as on the live site and the live site is showing all pages correctly. It’s as if CS-Cart isn’t “building” the pages on the local test site the way it is on the live site.



If anyone has any insight or can point me in the direction of relevant info I would appreciate it. Thanks.



Andrew

There are a couple of thing to check.



First, if you have SEO enabled, make sure that your .htaccess file points to the right path.



So if you have your store in:



C:\xampp\htdocs\your-cart



You need your .htaccess file to have:



RewriteBase /your-store



The other thing to be sure to check is your config.local.php



It should look something similar to:


// Host and directory where software is installed on no-secure server
$config['http_host'] = 'localhost';
$config['http_path'] = '/your-store';

// Host and directory where software is installed on secure server
$config['https_host'] = 'localhost';
$config['https_path'] = '/your-store';




Hope that helps,



Brandon

Thank you Brandon!



I had already changed the config.local.php file (I’m pretty sure because of a different post you made in the forums), but modifying the .htaccess file put the final nail in the coffin of this problem for me. I really appreciate the help sir.



Andrew