jquery info

Hi all



I posted this a little while ago:

[url]http://forum.cs-cart.com/showthread.php?t=19502[/url]



and I am wondering - i have another type of slideshow i used in a standalone site (not cscart) - works great, and I am now trying to get it to run in my cscart design.



in Ie8 I get an “error on page” in the lower left status bar - but it does work anyways, so I am just wondering - what version of jquery is cscart using and how can i tell if the functions I need are in that version?



I am trying to put this: www.smoothdivscroll.com codes in - so in a nutshell i have this part that would obviously be the problem with the cscart version













I tried removing a few things - but then it stops working

Thanks

They use jquery 1.2.6

Thanks Tony -you answered my original post previously - so 1.26 - but is there a way to find out why I am getting the errors? It would seem the calls I need for this slider are not part of the 1.26 standard jquery code - but obviously there is an overlap of loading the libraries correct?

You cant call 2 of the same libraries.

Tony - the original scroller code had 3 js files






I removed the first one - since I suspect that is the issue - the other 2 I would suspect are not part of 1.2.6 and therefore needed - but IE still gives me an error - works but not pretty for end-user

thx a million

The other 2 rely on jquery 1.4.2. so you cant do it.



its like having a php file that calls a PHP 5 function but you’re running PHP 4 on your server.



From the looks of it, the 2nd and 3rd files require at a minimum jquery 1.4.2 functionality.



If you read this [url]http://jqueryui.com/download[/url]



JQuery UI requires at a min of v1.3.2.



So yea, this cannot be done.

Thanks Tony - wow this is a real pain for sure.

I do understand what you are saying.

So essentially - we are tied to using the cscart jquery version library - we have no options to upgrade it to the latest - I am sure people have been asking - it would seem the best route for cscart to simply use the latest library instead of keeping it out-dated.



I had hoped this could be fixed like the last one - so I will have to change the type of slideshow to my previous one that you helped with - since that one does work - not as nice for sure - but will have to suffice.

thx

You can vote for jQuery here:



[url]http://cscart.uservoice.com/forums/40782-general/suggestions/547277-update-jquery?ref=title[/url]

Hey Tony - I voted - thanks



Quick question for you since you seem to know a lot on this subject. Is there a way i can find out what abilities I have with the 1.2.6 version of jquery being used in cscart? I mean I am just looking for a slide show of sorts and want to know which I can use and not



thx

[quote name=‘DELTA9000’]Hey Tony - I voted - thanks



Quick question for you since you seem to know a lot on this subject. Is there a way i can find out what abilities I have with the 1.2.6 version of jquery being used in cscart? I mean I am just looking for a slide show of sorts and want to know which I can use and not



thx[/QUOTE]



Very limited. CS uses an outdated version that they have rewritten for CS and they have also stripped what they deemed is not needed.

I think there are a few slider mods on the forums if you do a search. But until jquery is updated, it’s severely limited.

if anyone is interested i have done some changes to jQuery 1.3.2 and not come across any issues yet with cs-cart but is allowing my other jQuery code to also function!



if anyone needs it pm me and will see you the code as only have local at the moment