it seems that multiple suppliers

CS-CART: version 2.1.1 PROFESSIONAL



it seems that multiple suppliers



supplier A product A for 25$

Supplier B product B for 34$





shipping method custom manual



Cost based

if over 0$ then 10$ shipping

if over 50$ then 0 shipping



THIS IS USING PER ITEM AND NOT SUBTOTAL…



meaning i get 10$ for each item and not free since total is over 50$



WE NEED A WAY TO COMBINE suppliers…



bug++

seems it got fixed in 2.14






[QUOTE][!] Shipping rates were not calculated for supplier’s products if the “Display shipping methods to each supplier separately” setting was cleared.[/QUOTE]



Can one let me know what changed to make this work

[quote name=‘vanderex’]seems it got fixed in 2.14











Can one let me know what changed to make this work[/QUOTE]



Hello vanderex,



In order to fix this bug you need to replace the following part of code:



{else}{* not MVE or suppliers DISABLED*}
{if $settings.Suppliers.enable_suppliers == "Y" && $settings.Suppliers.display_shipping_methods_separately == "Y"}
{assign var="_suppliers_ids" value=","|implode:$supplier_ids}
{else}
{assign var="_suppliers_ids" value=""}
{/if}
{foreach from=$shipping_rates key="shipping_id" item="s_rate"}




with this one:



{else}{* not MVE or suppliers DISABLED*}
{assign var="_suppliers_ids" value=","|implode:$supplier_ids}
{foreach from=$shipping_rates key="shipping_id" item="s_rate"}




in the “shipping_estimation.tpl” file, located in the “skins/[CUSTOMER_ACTIVE_SKIN]/customer/views/checkout/components” (where [CUSTOMER_ACTIVE_SKIN] is the active customer skin) directory and replace the following part of code:


```php

{if $shipping_rates}

{if $smarty.const.PRODUCT_TYPE == “MULTIVENDOR” || ($settings.Suppliers.enable_suppliers == “Y” && $settings.Suppliers.display_shipping_methods_separately == “Y”)}

{assign var=“_suppliers_ids” value=“,”|implode:$supplier_ids}

{else}

{assign var=“_suppliers_ids” value=“”}

{/if}


```

with this one:

```php
{if $shipping_rates}
{assign var="_suppliers_ids" value=","|implode:$supplier_ids}

```

in the "shipping_rates.tpl" file, located in the "skins/[CUSTOMER_ACTIVE_SKIN]/customer/views/checkout/components" directory.

Thank you.

doesnt work…

same error

[quote name=‘vanderex’]doesnt work…

same error[/QUOTE]



Please try to clean up the cache.



Thank you.

ok i figure it out… partly…





IF you UNTICK “Display shipping methods to each supplier separately”



THEN



USERS-SUPPLIERS–> Shipping methods check all you need

(they will appear for any shipping methods that is set to the first (Default ?) supplier ( id=0 in source code)



BUT in Shipping/taxes → shipping methods

You need to have the default supplier (first entry) selected.



This will Still ADD the individual totals but will show one set of option that is common in ALL items in basket.

enabled so all suppliers for the items in cart need the same shipping methods in

USERS-SUPPLIERS–> Shipping methods



how to not add the totals ? no idea…







IF you TICK “Display shipping methods to each supplier separately”



then

USERS-SUPPLIERS–> Shipping methods is empty.



BUT in Shipping/taxes → shipping methods

You need to have the supplier selected.



this will display separate costs grouped by supplier

[quote name=‘vanderex’]ok i figure it out… partly…





IF you UNTICK “Display shipping methods to each supplier separately”



THEN



USERS-SUPPLIERS–> Shipping methods check all you need

(they will appear for any shipping methods that is set to the first (Default ?) supplier ( id=0 in source code)



BUT in Shipping/taxes → shipping methods

You need to have the default supplier (first entry) selected.



This will Still ADD the individual totals but will show one set of option that is common in ALL items in basket.

enabled so all suppliers for the items in cart need the same shipping methods in

USERS-SUPPLIERS–> Shipping methods



how to not add the totals ? no idea…







IF you TICK “Display shipping methods to each supplier separately”



then

USERS-SUPPLIERS–> Shipping methods is empty.



BUT in Shipping/taxes → shipping methods

You need to have the supplier selected.



this will display separate costs grouped by supplier[/QUOTE]



Hello vanderex,



Please post this message to the Bug tracker, in order our architects can investigate it in more detail.



Thank you.