Is There Any Way To Add A Text Into The Section Bar?

I am developing an add-on. It has 2 sections. I want to have a text on the buttons that it uses to switch between sections. Any idea how to do that? I don't want to override the entire template. And another question, is there a way to make some fields required? I am using a layout="searate" and scheme="3.0"

I am developing an add-on. It has 2 sections. I want to have a text on the buttons that it uses to switch between sections. Any idea how to do that? I don't want to override the entire template. And another question, is there a way to make some fields required? I am using a layout="searate" and scheme="3.0"

For example, emulate click on the tab with jquery

As for required fields, add cm-required class to the label of required field. E.g.


        

I forgot to mention something very important. I want to edit the settings page that is automatically generated by addon.xml. I want to make a field required when someone press the save button (if I can) and I want to show some text on the buttons that are used for switching between the sections from addon.xml

You can name each section you want as a tab. Review app/addons/my_changes/addon.xml.full for details or review the documentation. I do it all the time for my addons. I have a "Basic" tab for settings that are common to all my addons and then I have addon specific tabs (1 or more) applicable to each addon.

Thank you, I never knew that addon have this file. Ty so much

Also some useful details can be found here

https://docs.cs-cart.com/latest/developer_guide/addons/scheme/scheme3.0_structure.html

I find that they are using the .po file to change what I want.

I think this si the apropiate po line:

msgctxt "SettingsSections::sample_addon_3_0::section1"
msgid "Generic settings"
msgstr "Generic settings"

But how to do it in addon.xml file? I don't want to work with .po files at this point in time.

In this case use schema 2.0 in your addon

https://docs.cs-cart.com/latest/developer_guide/addons/scheme/scheme2.0_structure.html

Can I still deploy it to marketplace? I read that I need to use schema 3.0

Can I still deploy it to marketplace? I read that I need to use schema 3.0

You can try. But yes, they require 3.0 version

When did the version of addon.xml become a requirement? I thought they were only concerned if you are "selling through the marketplace".

When did the version of addon.xml become a requirement? I thought they were only concerned if you are "selling through the marketplace".

Yes, I think @bububeti meant "selling through the marketplace" by "deploy it to marketplace"