Installing new fonts to CS-CART


I've been recently trying to install a new custom font to my cs-cart (Open Sans font-family). The font was taken from Google Webfonts so it required placing an extra line of the code to . I've copied it from Google Webfonts and pasted into index.tpl.

Unfortunately the changes haven't come into effect. The file has been updated properly but the line I've added can't be visible in the page's source nor the site is using the new font. The same thing worked properly with the test version - with the full licensed one it doesn't.

Anyone knows what can be a problem?


P.S. Here's the code of the updated index.tpl


{if $page_title}
{foreach from=$breadcrumbs item=i name="bkt"}
{if !$smarty.foreach.bkt.first}{$i.title|unescape|strip_tags|escape:"html"}{if !$smarty.foreach.bkt.last} :: {/if}{/if}
{if !$skip_page_title}{if $breadcrumbs|count > 1} - {/if}{$location_data.title|escape:"html"}{/if}


{include file="meta.tpl"}

{include file="common_templates/styles.tpl" include_dropdown=true}
{include file="common_templates/scripts.tpl"}

{if "SKINS_PANEL"|defined}
{include file="demo_skin_selector.tpl"}


{include file="common_templates/loading_box.tpl"}

{if "TRANSLATION_MODE"|defined}
{include file="common_templates/translate_box.tpl"}
{include file="common_templates/template_editor.tpl"}
{include file="common_templates/design_mode_panel.tpl"}

{hook name="index:footer"}{/hook}

There is a free addon which can be used for this see here: FREE ADDONS: "Product Lables","Google Webfonts","Fluid Layout","Comming Soon" - Third-Party Add-ons - CS-Cart Community Forums


[quote name='JohnCarroll' timestamp='1359112676' post='153639']

There is a free addon which can be used for this see here: http://forum.cs-cart…__fromsearch__1



It took a while to adjust the addon but the font is working now. Thanks a lot for your help John!




I am having problems installing Open Sans font.

I have uploaded the addon, but I am unsure as to what I should do next.

I am working on V4.0.3

Any help would be appreciated.


Cancel that - it worked! Yeah!

Still doesn't work for me. I am using CS Cart v. 4.03.

I uploaded the folder upload/addons/iecsp_google_webfonts to the destination app/addons

Then I uploaded the folder /var/skins_repository/basic/customer/addons/iecsp_google_webfonts to the destination var/skins_repository/base/customer/addons

Then I installed the addon through the admin panel.

I chose a name for font (eg. Ubuntu) but nothing changed. I chose different names from Google Fonts but again nothing changes.

Do I do anything wrong? Do I miss anything?

If anyone can share what he/she did in order to work it would be appreciated a lot.

Thanks in advance.

Hi nikoz

Quite often you need to “clear cache” several times for things to work, not that I have had anything to do with this addon.


Hi BarryH

Yes I did that as well. I cleared the cache but still without any result.

If you use 403 then use this method I am describing at the end of this post.

No need for extra Addons.


Same thing happened for me. I un-installed it via the add-ons menu and then reinstalled. That's when it started to work for me.

All the best.

Ok. It worked. I un-installed and installed it again.

Thanks all of you.

[quote name='dvsgr' timestamp='1388474557' post='174276'] If you use 403 then use this method I am describing at the end of this post. No need for extra Addons. Fotis [/quote]

Where is describe dvsgr. I need to use webfonts witout add-on. As i asked following link. http://forum.cs-cart…itor-area-v4xx/

Damn ended up here from the other post.

Once again somehting that should be so simple not in their manual and no help here. BAH