Importing v2.2.4 to v3.0.2 misses products, orders, etc.

2.2.4 community import to 3.0.2 Ultimate does not import everything. The message says “Import successfully finished” but not true. I have increased memory to 90M and execution time to 50000 - but don't get any error messages anyway??. Tried 6 times now - even tried it with a new installation of 2.2.4 and only a couple of products and one order and that doesn't get imported fully.

Parts imported successfully are: Categories (structure and description/metadata but no images), shipping, payment methods, product features, banners, taxes, locations, website-content.

Failed to import: Products, product combinations, product images, category images, orders, order items, users, profile fields, global options, promotions, SEO rules.

Also it looks like settings, countries and order status' weren't imported (although they may not be anyway).

Sorry for the long list - hopefully this will narrow-down where it went wrong (perhaps there is a security setting that needs to be removed for the import to work). Still, strange that the resulting message is “Import successfully finished”.

Does anyone have any ideas (please!) or also had this problem as I had allocated this weekend to setting up 3.0.2 and would very much like to start making some progress.

I'd revert to your community edition.

I would then upgrade that to Pro and verify all is well.

I would then upgrade to 3.0.2 Pro and verify all is well.

I'd then upgrade to Ultimate.

I'm sure going from V2 community edition to V3 ultimate in one step would be an untested upgrade situation.

I am using the 2.2.4 / 2.2.5 to 3.02 Ultimate Store Import Add-On - this isn't the same as upgrading as upgrading you can only create one store, whereas importing creates additional storefronts. The Ultimate edition of this tool is for “importing CS-Cart 2.2.4/2.2.5 Professional and Community stores to CS-Cart Ultimate as additional storefronts” as described here: http://blog.cs-cart…-import-add-on/. It goes through the process but some items are missed.

Similar failure result from 2.2.4 to ultimate. I have even moved from internet to local network.

Weird results as some categories are lost. No luck for the second language for the missing categories and products except the admin panel second language.

I will try from 2.2.4 pro to 3.02 pro

Just trying to offer a way to get around your issue. If you want to hold to the quoted statement and also hold onto your problem, feel free. But if you want to solve your problem, you might try what I suggested. I do not know if it will work on not, it is just a different approach which removes a lot of variables but is more work for you.

Thank you for the suggestion tbirnseth. Unfortunately upgrading doesn't solve the problem as it doesn't create additional storefronts in one Ultimate installation (it upgrades one to one), whereas the import tool is for this purpose - it's just not working. I have submitted a ticket - but won't have much time in the week to investigate.

I appreciate the suggestion as I was pulling my hair out yesterday and needed to consider another approach. Many Thanks.

I've had the same issue upgrading to Ultimate as have a few others. I'm awaiting a response to my support ticket. I suggest you sit tight till the developers have a chance to review what is going on.

Just to clarify on this… Are orders and users supposed be be brought in via the store import tool from 2.2.4/2.2.5 via the import tool or do we have to export from old and import to new, I have images, categories, products, banners and seems like everything else but not orders or users.


Precisely why i am still with 2.2.5… too many issues…I'll wait til next year when they have everything solved…