Importing Users and Orders from 1.3.5 sp4 --> 2.0.8 Question..

I have a new installation of 2.0.8 i currently use 1.3.5 sp4.



My new 2.0.8 installation has all new products added and everything else already set up. I would like to export/import the User Accounts and Orders from my 1.3.5 sp4 installation in to my 2.0.8 installation.



My question is can i use the upgrade script to do this? If so what fields do i need to export from 1.3.5 sp4 in to the sql dump to use for the import. I don’t want any of my current work in 2.0.8 to be lost…



If it cant be done with the upgrade script, is there another way of doing it?



Any help on this matter would be greatly appreciated.



Best regards,

AleksB

I did the same thing…I kept my 1.35-4 store open while I modified 2.07. To import the current orders/users, you have to do a clean install of 2.08 on your server and then use the upgrade script. Perform a database backup on the clean install using the fields you want to import (orders, stats, users, etc) and then import that database into the 2.08 install that you want to use. This link below may explain it better. The entire process should only take about 20 min.

[URL=“http://forum.cs-cart.com/showthread.php?t=12958&highlight=upgrade”]

http://forum.cs-cart.com/showthread.php?t=12958&highlight=upgrade[/URL]

I had the same question a while back because I did the same thing as you. No one responded so I decided to just play around and see what would happen.



What I did is exported my users, order, and order items from 1.3.5 sp4 as a comma separated CSV file and then just imported the information into 2.x.



This worked pretty good, the only thing that was messed up was the tracking information. The information was still there, but it was just there 3 times.



The export and import went real smooth and I had no problems, but be sure to backup your database before you do anything.



Brandon

Would be easiest to upgrade the entire database then drop tables where you want them

Thanks, i went down the road sugested by “brandonvd”. This worked well for me.

I tried upgrading several times from 1.4.3 sp4 but something always went wrong. So a clean install took longer to set up but now its come together just fine.



Thanks for the help :smiley:

Aleks