Imported Categories And Products Not In Store


I have a new cart installed at as a development site until I’m ready to go live, then it will be moved to

All worked fine in demo mode, and I so imported orders, customers and products (using #########) from an existing different cart.

All seems to be imported OK but the cart comes up without a categories menu and without products. When I try and edit imported categories or products, I get an error in Admin …


Warning The Category xxxx is unavailable for this store.

Warning The Product xxxx is unavailable for this store.


I created a new test category called “test” and its appears fine on site menu and appears fine in category listing BUT it’s shown on the existing categories page under a separate title

category 1

category 2

category 3


Store: My Shop Name


All other categories appear above it.

It looks like all the imported categories and products are loaded under an undefined store name but I can’t work out how to move them all to under the one existing store name. I only have one storename. Does anyone know what’s wrong? Possibly the /store temporary subdirectory has messed things?



hi Tom,

you are right about bad linking between categories/products/orders.

please provide FTP access so our specialist assist you.

best regards,

WSA team

We are also ready to help you with this issue. Feel free to contact us

Now solved.

For anyone coming afterwards … the cart migration programme didn't assign a company number to company_id in the CSC db and company_id defaulted to zero.

company_id needed to be changed, for each Product, using phpmyadmin to the company number, in my case “1”.