.htaccess question

Im having a problem getting my secondary level .htaccess to work correctly. Maybe one of you gents can figure this one out.



My structure is /home/public_html/skins



In /home/public_html directory I have my primary .htaccess file which contains (among other things), this:




ExpiresActive On
ExpiresDefault "access plus 10 years"




FileETag none



SetEnvIf GEOIP_COUNTRY_CODE (RU|CN|KR) DenyCountry
SetEnvIf GEOIP_CONTINENT_CODE (AF) DenyContinent



Order Allow,Deny
Allow from 127.0.0.1
Allow from All
Deny from env=DenyCountry
Deny from env=DenyContinent




In my /home/public_html/skins directoy, my .htaccess looks like this:



Order Allow,Deny
Deny from all

Allow from all
Options -Indexes




Is there anything that stands out as to explain why the 2nd level .htaccess file isnt working? What I mean is, it is not blocking .php and .tpl files as it should be.

Try


Order Allow,Deny
Allow from all
Options -Indexes

Deny from all





I think it’s a precedence issue. I.e. you’re telling it to deny for php/tpl but then saying allow all.



Just a guess.

Thanks for the reply. The .htaccess in the skins folder is unmodified (except for the “Order Allow,Deny” line). I thought perhaps it was a precedence issue so I added that line, however that did not seem to fix it.



Like I said though, thats the default .htaccess from cs-cart so I assume thats not the problem.


[quote name=‘tbirnseth’]Try


Order Allow,Deny
Allow from all
Options -Indexes

Deny from all





I think it’s a precedence issue. I.e. you’re telling it to deny for php/tpl but then saying allow all.



Just a guess.[/QUOTE]

Sorry, you’ve reached the extent of my htaccess knowledge… Good luck. Please post your solution here when it’s known.

my advice would be to re-upload the default htaccess files from the cs-cart ZIP file. that worked for me (i am a mac user and something went wrong when i uploaded after decompressing the zip file instead of uploading direct from the zip). if that makes any sense ;p

[quote name=‘tbirnseth’]Sorry, you’ve reached the extent of my htaccess knowledge… Good luck. Please post your solution here when it’s known.[/QUOTE]



Problem turned out to be an error with my apache config. httpd.conf was not parsing .htaccess correctly.