How to: Thumbnail images in admin 2.0

I have this working in 2.1.2 this is what I did:


  1. I followed the instructions in the first post on this page.
  2. I exported all my products and copied the image url column into the thumbnail column.



    See attached image

first of all thanks a lot for your module brandon

now in order to not erase the list column just do the following

find in file skins/{yer admin skin}/admin/views/products/manage.tpl

[HTML] $c_url&sort_by=list_price&sort_order=$search.sort_order"|fn_url}" rev=“pagination_contents”>{$lang.list_price} ({$currencies.$primary_currency.symbol})[/HTML]

and add AFTER

[HTML]Thumb[/HTML]

also find

[HTML]

[/HTML] and add AFTER [HTML]

{include file=“common_templates/image.tpl” image_width=‘50’ obj_id=$product.product_id image=$product.main_pair.icon object_type=“product”}[/HTML]

can anyone tell me how to add a new column to admin products

I suppose a new table in database must created and then just add a column to the manage.tpl file



can someone tell me how?brandonvd i want a “cost” column like yours

I didn’t want to take over this thread for the cost thing so I created a new one at [url]http://forum.cs-cart.com/showthread.php?t=22732[/url]



I hope that helps you.



Brandon

Would it be possible to have this somehow as stand alone addon with no php or tpl edit required?



Would buy addon that adds customer order details page products small thumbs, order details page in admin product thumb and adds admin category product pictures in one go.






[quote name=‘elk’]first of all thanks a lot for your module brandon

now in order to not erase the list column just do the following

find in file skins/{yer admin skin}/admin/views/products/manage.tpl

[HTML] $c_url&sort_by=list_price&sort_order=$search.sort_order"|fn_url}" rev=“pagination_contents”>{$lang.list_price} ({$currencies.$primary_currency.symbol})[/HTML]

and add AFTER

[HTML]Thumb[/HTML]

also find

[HTML]

[/HTML] and add AFTER [HTML]

{include file=“common_templates/image.tpl” image_width=‘50’ obj_id=$product.product_id image=$product.main_pair.icon object_type=“product”}[/HTML][/QUOTE]

i thought the module work ok, but i was wrong. It can’t read the image. When i posted my message, i haven’t images to my products yet and i thought that the no_image.gif was ok. But now i upload some, clear cache, clear smartoptimzer cache and stil no image.

I exported the products images. The thumnails column is empty.

If i copy the images links to the thumbnails, then the thumb does appear at admin but the customer can see double images to the product description

i have set the sizes to the thumbnails page

so the only way seems to be to upload thumbs manually



any idea please?

i doesn’t work. it can’t read the thumbnail

i have cleared all my cache but still nothing.

i also remove my thumbnails (from folder) and then surf the page in order to recreate and still doesn’t appear at admin product details



any help.?? (ver 2.1.2)

Any fix ?

not working with 2.1.2