How to stop CS Cart from making a copy of my images

Good morning to all,

I noticed that CS-Cart makes a copy of the thumbnails that I’ve uploaded after I assign it to a product. I upload the images to the server, then use the “server” link to point to the image from the product details page. I keep my images in a “images/small/category” but I noticed that right after I point to the image a duplicate of it is created in “images/thumbnail”. Does anyone know how to keep this from happening? or if there’s a workaround for it?

Thank you


The copy in the thumbnail directory follows this naming structure:



If so, that’s simply how the cart works. It auto-generates thumbnails for the images it displays, even if you upload them at whatever size you upload them at. There’s nothing you can do about it. Hard disk space is cheap, so it shouldn’t be an issue.

If you want it “fixed” it would require a rework of the way the entire image system works with the cart, which would be a huge waste of time and money.

Not sure what version you are using.

Problem may be here


If there are any settings to size image or change format, after doing this cs-cart will make duplicate to its directory…

I tried disabling that auto-generate thumbnail option but unfortunately that wasn’t the problem.

Yep, that is one of the filename structures. It turns out that CS-Cart actually makes 2 copies (and even 3 if u decide to export a csv record of the images, it creates it in the backup folder) of the image. I’ve started inserting the thumbnail images first, then i thought I’d upload the large images after using the CSV option. CS-Cart creates one copy in the product folder (using the original filename) and another one in the thumbnail folder (using the filename structure phazei posted).

My only solution so far is created a folder called “uploads” and i upload all the images to that folder, then after i’ve linked it to the product and cs-cart has created it’s own copy of the image i just delete the images from the “uploads” folder. There doesn’t seem to be any bad side effects to this yet. I tried using the “local” image link option but it didnt work for me :frowning:

Btw, thanks for the help and suggestions!