How do I remove "powered by" (not change)

Hi,



I want to take out the link “powered by” so that it does not appear on my page at all.



Can anyone guide me on exactly how this is done?



Thanks

Open the bottom.tpl file in your skins directory and delete the code for it.



Or you can follow the directions in the knowledge base but instead of entering new code for the powered by section just leave it out and instead only enter the copyright code, [URL=“CS-Cart Documentation — CS-Cart 4.15.x documentation”]CS-Cart Documentation — CS-Cart 4.15.x documentation.

I have never done code, what bits do I need to edit and how? ie: step by spep … :confused:

What are you trying to remove exactly? Do you want to remove the entire copyright and everything?



If this is the case, in:



skins/your-skin/customer/bottom.tpl



Remove:


```php

{$lang.copyright} © {if $smarty.const.TIME|date_format:“%Y” != $settings.Company.company_start_year}{$settings.Company.company_start_year}-{/if}{$smarty.const.TIME|date_format:“%Y”} {$settings.Company.company_name}. {$lang.powered_by} {$lang.copyright_shopping_cart}

```

The better way would be to make a new file called:

skins/your-skin/customer/addons/my_changes/hooks/index/bottom.override.tpl

And just leave it blank. This will remove the copyright stuff and you won't actually be changing the CS-Cart files.

Brandon

OK, I just had the same question myself, and tried the second method, but it didn’t work for me.



I didn’t have any of the directories after skins/your-skin/customer/addons/. I just created them and placed my file there, cleared cache, and nothing changed. Hmmm. Just for grins I cut all that and saved the empty file to the server, and that did not change anything either.



Was I supposed to put anything in this new file beyond the desired footer text? Mine just has the opening/closing p tags and the text in between, and nothing else.



I realize I could just go edit the original file, but I’d rather make things easier going forward.

You need to put something in the bottom.override.tpl - try using just a
.



Also note that this will only the copyright line - the search and quick links are outside the hook. I have requested that they move the hook to encompass the whole bottom area:

[url]http://forum.cs-cart.com/vbugs.php?do=view&vbug_id=1412[/url]



They, instead, gave us a second hook for the quick links but still excluding search.



Bob

The your-skin folder is what I call your skin. So basically if you are using the basic skin for your customer side than it is:



skins/basic/customer/



If you are using the artificial casting skin than it is:



skins/artificial_castings/customer



Hopefully that will help. If you need more help, just post on here and I’ll see what I can do.



Brandon

[quote name=‘brandonvd’]The your-skin folder is what I call your skin.

[/QUOTE]



Yes, I caught on to that. Thus, the current path is:

/skins/solitude/customer/addons/my_changes/hooks/index/bottom.override.tpl



since I’m using Solitude. (Which happened to have, almost to the hex number, the same colors as my old cart. How cool is that? :-D)



and I do have data in that file, specifically:

© {if $smarty.const.TIME|date_format:"%Y" != $settings.Company.company_start_year}{$settings.Company.company_start_year}-{/if}{$smarty.const.TIME|date_format:"%Y"} {$settings.Company.company_name}



and only that, no doctype or anything else.

Can anyone spot what I'm doing wrong? Is there something I need to turn on in the admin maybe? This is the first time I've done anything involving hooks.

Make sure the ‘My changes’ addon is active in Administration->Addons.



Bob

[quote name=‘jobosales’]Make sure the ‘My changes’ addon is active in Administration->Addons.

[/QUOTE]



Cha-CHING! Thank you… working fine now.

OK, should have asked this – how do I also eliminate "Skins by Template World?

I have followed this [url]CS-Cart Documentation — CS-Cart 4.15.x documentation



and that got me to the stage of changing the CS CART name to my company name. But still when clicking on the link I ended up going to the CS CART home page.



So then I changed the bottom.tpl file located in

skins/your-skin/customer/bottom.tpl and put my website url to replace the CS CART one.



Now I’m left with “Powered by Tech Gems” and when I click on the link it takes me to another window opening with my website being displayed.



Take a look www.techgems.co.uk



I’d like to get rid of the whole thing so it does not show “Powered by Tech Gems” at all.



By the way I do have “My_changes” enables in my Add Ons.



Please help