Hitting Max Usergroups Limit. Why?

I’m setting up a product and I am going through the list, checking the box for each usergroup. Now that I’ve gotten to about 80, I can no longer add usergroups!!

First I tried clearing my browser’s cache and cart's cache. Then I tried a different browser. Different computer. Better internet connection. Nothing worked. I can save changes to the description on this product but can’t add any more users!

I called the server and gave them my IP and they could find no errors in the logs.

Anyone encounter such a problem? Is their a max limit? How to fix?

Found cause.

In table cscart_products

usergroup_ids was set to varchar(256)

I upped it to


Interesting that it's a varchar and not an unsigned integer

In the product table the user group id is a comma delimited field of all the user groups associated with that product.

Sent from my iPhone using Tapatalk

Okay, so it wasn't really a limit of the number of usergroups (literally) but simply that the length of the field was exceeded by the comma separated values string.... That's spooky since the last one could be truncated from 122 to 1 (which is usually admin group).

Hello Triplets,

Just curious, why so many usergroups is needed? And how quickly working CS-Cart with it?

Thank you.

So far all is working good. ( once we fixed the limit issue in MySQL) We have some products with thousands of user groups. We sell school products and every school is setup as an unique user group.

Sent from my iPhone using Tapatalk