Help - am getting desperate!

[font=arial, sans-serif][size=3]I ran into a very weird issue yesterday. I was just editing a little thing on my sisters website and discovered a lot doesn’t work anymore that was still working fine last week. For example: the tabs on product pages as -Removed link for various reasons) are simply not working.[/size][/font]

[font=arial, sans-serif][size=3]It’s also not showing a rotating product banner on the homepage, the tabs in de admin area are not working, and so on.[/size][/font]

[font=arial, sans-serif][size=3]As far as I know nobody has been into the website … and I also did not change anything for sure (just now I did to check a couple of things). I even put back a backup from some time ago (overwrote all files) and still, nothing.[/size][/font]

[font=arial, sans-serif][size=3]My host is saying absolutely nothing has changed on the server.[/size][/font]

[font=arial, sans-serif][size=3]I’m guessing it has something to do with javascript not being executed correctly but my knowledge is not good enough to fix this. [/size][/font]

[size=3][font=arial, sans-serif]I’d really, really appreciate any tips on how to solve this asap because the site is live but hardly accessible.[/font][/size]

[font=arial, sans-serif][size=3]Thanks![/size][/font]

Hi did you try to change temporarily the skin and back again.

I assume you cleared all your cache, and if you have any smart optimizer you also deactivated it.

I would need a littlle bit more info on your installation…

Firebug indicates the tabs.js is in /var/cache/js/tabs.js

In a regular installation the tabs.js is in js/tabs.js

Hope you find soon the solution.

Hmm, it seems to have something to do with smartoptimizer. I removed it and things started to work again.

How this could have worked for 2 years to stop working now is a mystery though… let’s see if I can get it to work with SO turned on again. Thanks for the tips, i’ll try changing the skin back and forth.

Update: well, it’s working again with SO. I have no idea what could have caused it, but I’m already happy it’s ok now.

That went a lot faster then expected (I spent 4 hours on this yesterday!)… :D

Glad it was that simple !

Smartoptimizer is a nice tool but sometimes you need to clear everything in the cache folder and start again.

Don't now why!


I know fotis, that I had already done 10 times, but it didn't fix it! What did fix it is turning SO completely off (I made a htaccess without any optimization) and turning it on again.



Yes I know .

This is why I told you in my first post to deactivated and not only clear cache.

Do you have 777 ? This. Might be a reason.

Flow the same thing happened to me yesterday… I couldn't change the statuus of orders… when you clicked on the status button, nothing would happen… clearing cs-cart cache didn't fix it, but clearing smartoptimizer did…

Maybe SO had an off day yesterday.

I’m not using 777 btw … thanks for the tip Fotis, it did certainly save me another evening of #$@$ ;)