Getting rid of /index.php from top logo

Does anyone know how to get rid of the /index.php in the link from the top logo? I tried putting rewrite in .htaccess but it is not working. I have seo addon turned on.

(Strangely, when I looked at my .htaccess before, I added this, there was nothing there but all other seo urls were working.)

This is in 2.1.1, upgraded, not fresh install.

I also found with this that when on a sub category product page and you click on the logo it would go to homepage with the url wrong such as /cat/subcat/index.php

how i resolved this was to grab the URL that is set in admin > settings - now sure if this will work for you but was my solution on 2.1.1


Hope this helps

That worked perfectly. Thank you!