Form Builder - No field options

No field options are showing when I select Form builder. As a result all the forms I create never show up on my site. Also my contact us form has no fields.

I have seen several threads about these issues, but no resolution. I have followed all the recommendations such as confirming Form Builder is enabled in Add-Ons, uninstalling/reinstalling, clear cache, etc. This has not resolve it.

Does anyone have any other suggestions or resolution. Screenshot of my Form builder is attached.

Other than that, after years of zencart, CS-Cart is awesome!


Wich version are you running? I had similar problem back in 2.6* days

I am using 2.1, the latest on the cs-cart site.


i’m also facing the same problem, any solution so far?

my contact us form is gone

i never seen “form builder” controls?

any help?

this is the response from support:

This issue may have occurred because some files are missing . Please check the files in the directory skins/basic/admin/addons/form_builder/views/pages/components . There should be two files: elements_type.tpl and pages_form_elements.tpl. They should not be empty and should have permissions 777.

This did not solve it but it pointed me in the right direction.

This is what I did to solve it:

I looked where they said, and found my pages_form_elements.tpl was named pages_form_elements.tpl0000777.

I renamed it back to pages_form_elements.tpl and changed permission to 777.

However, that still did not solve my Form Builder no fields issue.

So I uninstalled the Form builder add-on from the Admin area then reinstalled it.

When I went back into the directory the reinstalled form builder file was back to pages_from_elements.tpl000077.

I renamed it back to pages_form_elements.tpl and changed the permissions to 777.

When I went back into the Admin area my Form Builder worked!

Hope this helps you!



elements_type.tpl file is missing?

there is only pages_form_elements.tpl0000777 file inside

what shud i do?

wow, thank you so much,

it worked even though without elements_type.tpl file

great work

Glad it worked for you! That issue was driving me crazy too.

I don’t know how necessary it is, but you can get the elements_type.tpl file from install folders you downloaded to your desktop and upload it manually. Mine was there so I didn’t have to upload it again.