First Time Pageload Very Slow In V403

One of our webshop in v403 has a strange performance issue. The first time the homepage is accessed it can take up to 30 seconds before the page is loaded. From then on there are no more issues with the frontend.



The client have reported this issue and I have noticed this on two of my PC's. The strange thing is I cannot seem to reproduce the issue. After I have accessed the webshop once there is no more issue. This holds true:[list]

[]across different browsers

[
]after I cleared browser cache

[*]after I cleared CS-Cart cache → now first time page load is about 5 seconds. Slower but no where near the 30 seconds on initial load.

[/list]

I am a bit lost about this issue. I do understand the concern of the client. New customer think there is a problem and will not wait 30 seconds.



All information is welcome.

You could try using Pingdom to test the TTFB and identify any reasons why the page load time is so poor.

[quote name='StellarBytes' timestamp='1390570781' post='175958']

You could try using Pingdom to test the TTFB and identify any reasons why the page load time is so poor.

[/quote]



Thanks for the quick replay. I have tried similar tools. However I do not exactly know the exact conditions in which the problem occurs. Now pingdom gives a 95 out of a 100.

It could be anything - you can also try testing with your browsers debug tool. Firefox is pretty good for this purpose.

Did you ever find a solution for this? I have the same exact issue with v4. Version 2 is running like butter on the same server and the v4 is always slow to load the first time and then it speeds up. When you come back the next day, it's slow again on the first load. I tried pingdom and experience the same. Cs-cart support always blames the “server configuration” and the hosting supports blames “poorly written code that calls over 500 queries to load for one page”. Anyone running version 4 sucessfully with decent speed? Which hosting company do you use? How many products and categories?

[quote name='novitas' timestamp='1397450133' post='181660']

Did you ever find a solution for this? I have the same exact issue with v4. Version 2 is running like butter on the same server and the v4 is always slow to load the first time and then it speeds up. When you come back the next day, it's slow again on the first load. I tried pingdom and experience the same. Cs-cart support always blames the “server configuration” and the hosting supports blames “poorly written code that calls over 500 queries to load for one page”. Anyone running version 4 sucessfully with decent speed? Which hosting company do you use? How many products and categories?

[/quote]



Please try Searchanise. It is a good solutions for stores with the big amount of products.



If you want to optimize the store code, please contact us at contact@ecom-labs.com or http://ecom-labs.com . We can examine your store and optimize the code for your needs and catalog structure.



Thanks.