Feature Import

I'm seeing really inconsistent results from importing product features. I'm also having trouble finding any documentation to help.





This entry works:



“(General) Top Style: S[Padded]; (Capacities) Load Capacity in Tons: O[0.75]”



This entry doesn't work - Features that don't exist are added, but have no values (or just one out of three) appear under any products:



“(General) Manufacturer: S[Hilman]; (General) Top Style: S[Padded]; (Capacities) Load Capacity in Tons: O[0.75]”



BTW, the documentation says that you have to add the features first, that seems incorrect, the import routine seems to add features and groups just fine.



I have tried every slight formatting change I can think of, with multiple “feature types” (where are those documented?). I've also used the Feature ID in the import, it's not listed in most samples, and I don't see a difference if it's there or not.



Is there a limit to the number of features you can import at one time (two?)?



Is there some sort of limit to the length of a feature name?



Are there logs generated anywhere to help me troubleshoot what is happening?

It will add feature values but the feature must be set in features for it to assign those values to.



Also I import features and sometimes have to wait a while for them all to propogate,



John

It adds the feature “definition/group/whatever” when I import, even if that feature doesn't exist - but that feature doesn't get assigned a value. So when I look at the product in the admin, the features are listed there, but there is no value in the box beside it.



I've also tried adding the features in the store, and matching the ID, name, and group in the import. It still only imports one or two values for those features, leaving the others blank.



I assume if I was messing up the format somehow it wouldn't import any features at all.



I checked to see if it was just a caching issue (since you mentioned it taking a while to propagate) but I don't see those values being added into the database either.

Note Sure… I always import using .csv comma sep, and tab



I have attached my test record if that helps… I always create the feature first in products features. So in there i have a feature called Manufacturer and 1 called Colour, set as extended and ticked to show all categories



John

features_test1.zip

I made a simpler CSV, and tried again (I was importing ALL product fields). These features already exist in the store, I tried with and without the feature Ids in place.





Product code, Features

H001, {57} (Features) Top Style: S[Padded]; {59} (Capacities) Load Capacity in Tons: O[0.75]

H003, {57} (Features) Top Style: S[Smooth Steel]; {59} (Capacities) Load Capacity in Tons: O[0.75]

JH5GPlus, {60} (Capacities) Usable Toe Depth: O[2.30]; {59} (Capacities) Load Capacity in Tons: O[5.00]; {62} (Capacities) Stroke: O[5.50]



The first two products have two features, they get imported correctly.



The third product has three features listed, and only “Stroke” gets imported.

publication_out.zip