Exporting data

I looked at some of the other posts concerning Exporting, and no one seems to have problems like mine.

My CS-Cart store is not public yet (although it IS “open”). It’s in a subdirectory of my website. I have entered a bunch of items. Now I want to export them and then import them into another CS-Cart store on a different website.

However, whenever I try to Export, I don’t get anything.No errors, no messages, no products, no nothing.

I don’t want to have to enter all these items twice (once for each website). Does anyone have any ideas as to why my Export isn’t working?


Did you look at your PHP error log? It is possible that the directory the csv file should be put to is with wrong permissions… ???

ok, I’ll bite. What php error log? Would that be in CS-Cart or on my website end?

I just tried it a few more times. Each time it says the Export was successful. But nowhere can I find a file for it. I tried both Direct Download and Server. Direct Download gave me a 404 error.

As far as I know, the file permissions are correct.

I don’t know anything about a php log. Is that through CS-Cart or the website itself?

Every time I try, it says the export is successful, but I can never “find” it. I’ve tried both Server and Direct Download I think it’s called.

I really hate to use my support credits for this.

I’ve posted replies twice to this thread and they don’t show up. I’m trying again.

As far as I know, the permissions are right.

Is the PHP log you mentioned in CS Cart or my website?

I’ve tried the export several times more. Each time it says it was successful, but I don’t get any data. Anyone else have this happen? This is quite important to me at this time. If no one has any ideas, I’ll have to pay for support on it.


Try exporting just 1 or 2 product from the admn/catalog/products window,

if this works you could select them all and export them this way instead of admin/export data

ok, looks like I have it somewhat working. It WAS the file permissions. Had to change the var directory to 777.

Now, next question.

I was able to export the products and images and imported both successfully into the other website’s CSCart. HOWEVER, none of the imported products show the images. How do I get them “connected” again without having to edit each and every product?

Ok, I have made some progress. I managed to do the export/import and get the thumbnail images. But nothing I do seems to work to get the larger popup images exported/imported.

I’m doing this from one CSCart installation to another. It shouldn’t be this difficult, in my opinion.

Any ideas?