Export from 1.3.5 to 2.1.2, image import difficulty

Maybe I was wrong in thinking that exporting/importing products and images from 1.3.5 to 2.1.2 would be straight-forward. Importing the products were no problem, but the images have been a different story.

The scenario:

I’m trying to import products and images to a seemingly working version of cs-cart on a windows xampp stack. It seems that the permissions are fine. First i loaded it with the sample data and everything worked fine. So i wiped the sample data when i imported my products and all went well except no images. i have the images on the server at “/images/backup” with two sub-folders of “detailed_images” and “product_images”. I then tried exporting/importing the images and it didn’t work, of course. I say “of course” because i can clearly see that the links in the .csv are wrong. i fixed the links in the .csv to have the right paths and re-imported but nothing still. I don’t know enough about cs-cart’s db structure to verify what’s going on.

Am I missing something obvious? (please tell me i am)

I see tables…

cscart_products table has column “product_id” that matches

cscart_image_links column “object_id” which has rows for all products, but

cscart_image_links column “image_id” is blank and

cscart_images has no entries

Are these even the correct tables? Help?

Try moving the images to the Database instead of the file system and then export from 1.3.5 and import into 2.1.2. Should work.