Error moving cs-cart 4 to another domain

Hello I have been working on a new store with cs-cart 4 on a test domain. Now I want to move this to another domain. I changed the store-url in the stores section in the backend and changed the configlocal.php in the root directory of the install (changed the domainnames). Then I changed the domainname of the package in the Direct Admin. Now the following error occurs:

Warning[color=#666666][font=Arial, Helvetica, sans-serif][size=3]: include(/home/packtrack/domains/ [[/size][/font][/color]function.include[color=#666666][font=Arial, Helvetica, sans-serif][size=3]]: failed to open stream: No such file or directory in[/size][/font][/color]/home/packtrack/domains/[color=#666666][font=Arial, Helvetica, sans-serif][size=3] on line [/size][/font][/color]2309

What do I do wrong or what am I missing? (I changed the domainnames to domain 1 and domain2 on purpose in this message by the way) I can see that the include still points at the old domain, so I am something missing but what?

Please help?



Yes i have de same issue…

Please, someone can help us with this.

Contact helpdesk and please post the response. Since V4 is so new, there are probably quite a few bugs of this nature that require a direct DB update in addition to the settings in the admin area.

I just upgraded to 4.0.2. and I am getting the same issue. Since this is a few months ago, did you get a fix for this problem?

I am having the same problem when moving the version 4.0.2 install to another folder on the same server. I had to revert back to my prior version. Has anyone found the solution for this?

Just moved from temp domain to real domain and got this same error. Has cscart support provided a solution? I really dont want to have to start from scratch.

I've setup a ticket, no response yet.

Sent from my EVO using Tapatalk 2

I set up a ticket also. Will post if I get a response.

FWIW My admin panel was working fine even though the front of the site was broken. In a futile attempt to repair the front end we uploaded the entire file system from the original site. Once we did it broke the front end and now the error messages are pointing to missing file in the old temporary domain.

I did a search for the temporary domain and found tons of references to it in the cache files. Particularly in the registry cache. I plan to backup the current cache and then erase what is on the live site. Will let you know.

Try clearing cache admin.php?cc

Thanks! I thought I had tried that but apparently not. I was able to get into the admin panel after running admin.php?cc and then I changed the store path in the admin panel and that resolved the issue for me. Good thing too as I received an email from support saying it was going to be 2-3 days before they could get to it. I've closed the ticket.

Yes, clearing the cache is the best first step. If you can't get to ?cc to clear the cache, then there is a brute force alternative. Rename the cache folder, then upload the default cache folder from the original extracted installation files. Go into the customer cache files and change the path to the correct path for your server.

change - /var/lib/jenkins/jobs/cscart-build-staging/workspace

to your correct account home path in the following files



Then once you have access to admin go in and set the store domain(s) to the correct locations(s). The program will then regenerate all of the appropriate cache folders and files.

You may also have to fix the logo and banner images.

Anything under var/cache should be rebuilt as needed. No need to move any new cache files into this directory. That's why it's in “var”.

Thank you - I just moved a test/dev site from a sub directory to root and while the primary site worked fine after changing the Store URL in the admin and in config.local I could not access the admin. After two hours and 10-15 tries of moving files back and forth, deleting cache, disabling cache, edits, scouring the database for a path entry etc etc I found this thread and manually deleted my cache (which shouldn't have been there) and boom I'm in right away.

CS-Cart version 4.3.

Error: [color=#555555] failed to open stream: No such file or directory in /home/site/public_html/app/functions/fn.common.php on line 2120[/color]