error message when purchasing a downloaded product


I’m having a strange error when a customer purchases an online product. the order processes fine, but when they go to the download screen, they get the error:


Access Denied

you can see the link here:


I also noticed, that the cart drops to http:// versus https:// when it was processing the credit cards…

any thoughts on the matter would be much appreicated…


No error. works fine for me


I am having the same problem with the error message, did you ever managed to sort this out and if so I would appreciate your help if you could tell me what you did to cure this problems

Many Thanks



I’m having the same problem, but it only occurs with a few files here and there. For instance, I just had a customer place and order with 3 items. 2 downloaded fine and the 3rd file resulted in the error. It was set up correctly in the admin and pointed to the right file. Another time, the customer had 20+ files and one of them resulted in the access denied error.

I’m scratching my head here.

Additional info… I am logged in as the customer right now… I uploaded the file again and left the old one (the one that resulted in the error) intact. When I tried downloading again, both files worked without error. :confused:

…and I deleted one of them and now the other one doesn’t work. I have tried re-uploading the file about 10x now and get the access denied error every time. The file itself is fine, so I’m not sure why access is denied.

When I check out as a customer the file name and size is there under downloads when I click on the name of the file to download i get a “403 Access denied you don’t have permission to access the page”. I even gave permissions to the files. Im uploading from a CSV sheet too also is there anyway to change the Activation Mode to Immediately in the CSV or a setting somewhere, so I dont have to go through each product changing that as well? I can click the file in the Admin error of product and it downloads fine and works from. Why doesn’t this work through the customer side.

I am having this exact problem. I can't figure out why some products are giving me the error and not all. Same setting used on all the products. Order shows as processed, but access is denied from the download link in the customer's email, and shows as not available or expired in the download list. I haven't seen anyone post a fix for this.