Error After Upgrade To 4.2.3

I keep getting the error below when i try to access certain pages in the storefront whiled logged in as any user. I don't get this problem when not logged in.



Message



[color=#000000]You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'FROM cscart_users WHERE user_id = 1' at line 1 [/color]b[/b]

[color=#000000]SELECT FROM cscart_users WHERE user_id = 1[/color]



Error at



[color=#000000]app/Tygh/Database.php, line: 677[/color]

Backtrace

File: app/Tygh/Database.php Line: 333 Function: _error File: app/Tygh/Database.php Line: 158 Function: query File: app/functions/fn.database.php Line: 54 Function: getRow File: app/functions/fn.users.php Line: 58 Function: db_get_row File: app/functions/fn.cart.php Line: 3139 Function: fn_get_user_info File: app/functions/fn.cart.php Line: 2703 Function: fn_get_customer_location File: app/functions/fn.cart.php Line: 1358 Function: fn_calculate_cart_content File: app/functions/fn.users.php Line: 1124 Function: fn_extract_cart_content File: app/functions/fn.users.php Line: 2035 Function: fn_init_user_session_data File: app/controllers/common/auth.php Line: 71 Function: fn_login_user File: app/functions/fn.control.php Line: 574 Function: include File: app/functions/fn.control.php Line: 357 Function: fn_run_controller File: index.php Line: 25 Function:

fn_dispatch















Any ideas? I only started to get this error after upgrading to 4.2.3

i found the culprit. An addon that is not compatible with 4.2.3. Disabled it and its now working fine

What was the addon?

I just up-graded and now when i click visual editor and edit content site, I just land on “[color=#000000][font=Tahoma][size=5][center]Sorry, service is temporarily unavailable.[/center][/size][/font][/color]”

I can’t even see how or where to activate the paypal login feature. Something still very not intuitive on cs-cart :-(

and now my site is down with the [color=#333333][font=Tahoma, Geneva, sans-serif][size=5][center]Sorry, service is temporarily unavailable.[/center][/size][/font][/color]

I'm starting to have big regrets now

We are having huge the same problem.



Anybody has any solution.

Again, add the code above to config.local.php (or local_conf.php) It will at least show you the error.



tony

That didn't work for me Tony. Is there a particular line or point to add it? When I did my website would only load a blank page.

Cheers

Chris

Hi Tony,



Could you please let me know what code you refering for adding to [size=4]config.local.php (or local_conf.php)[/size]



Thanks,



Albert

Add


define('DEVELOPMENT', true); // enables SQL diagnostic output
error_reporting(E_ALL); // Reports all errors, notices and warnings
ini_set('display_errors', true); // shows errors, notices and warnings to the sceen


To your config.local.php or (what I use to keep test sites and product sites separate) local_conf.php.



It's just a define so it can go anywhere in the file (but end is probably preferable).

Here is error in admin log that it shows.



[color=#333333]Database (error)[/color]

Error:[color=#333333] [/color][color=#333333]You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'FROM cscart_users WHERE user_id = 1' at line 1 (1064)[/color]

Query:[color=#333333] [/color][color=#333333]SELECT FROM cscart_users WHERE user_id = 1 [/color][color=#333333]

Backtrace››[/color][color=#333333]

interioradmin.php (fn_dispatch): 27

app/functions/fn.control.php (fn_run_controller): 357

app/functions/fn.control.php (include): 574

app/controllers/backend/profiles.php (fn_get_user_info): 427

app/functions/fn.users.php (db_get_row): 58

app/functions/fn.database.php (call_user_func_array): 54

app/Tygh/Database.php (getRow): 158

app/Tygh/Database.php (query): 333[/color]

There are no fields in the SQL statment (that's the error). Which addon is truncating that within their hooked code would require detailed review.



Suggest you disable all 3rd party addons and see if the problem continues. If not, then enable 1 by 1 till you find the culprit.



If a problem when all 3rd party addons are disabled, contact helpdesk and let them sort it out (or they might know of an open issue).

[quote name='albertpro' timestamp='1414364669' post='195269']

Here is error in admin log that it shows.



[color=#333333]Database (error)[/color]

Error:[color=#333333] [/color][color=#333333]You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'FROM cscart_users WHERE user_id = 1' at line 1 (1064)[/color]

Query:[color=#333333] [/color][color=#333333]SELECT FROM cscart_users WHERE user_id = 1 [/color]

[color=#333333]Backtrace››[/color]

[color=#333333]interioradmin.php (fn_dispatch): 27

app/functions/fn.control.php (fn_run_controller): 357

app/functions/fn.control.php (include): 574

app/controllers/backend/profiles.php (fn_get_user_info): 427

app/functions/fn.users.php (db_get_row): 58

app/functions/fn.database.php (call_user_func_array): 54

app/Tygh/Database.php (getRow): 158

app/Tygh/Database.php (query): 333[/color]

[/quote]



Have you tried to disable all the 3rd party addons?

[color=#282828][font=arial, verdana, tahoma, sans-serif]

Hello,

We are having an issue with the latest version of cs cart. CS-Cart 4.2.3 ec46f3715c17a1cf0facbf7a4cd5ef269ee4c7da



Links to certain product files (in files to sell tab) stopped working. The file isn't in the folder its directed too.



It seems to be only large files like 200-400 MB.



When adding a file it says Error File could not be uploaded.

adding files another way it gives you a white page and the url is that to login.

And strangely enough it does work after moving a file to a different directory .

Please help. [/font][/color]

It could be that you are exceeding your hosting setting for maximum size of POST data. Contact your host and work with them.

Thank you very much,



I disabled addon and it works.






[quote name='tbirnseth' timestamp='1414365207' post='195270']

There are no fields in the SQL statment (that's the error). Which addon is truncating that within their hooked code would require detailed review.



Suggest you disable all 3rd party addons and see if the problem continues. If not, then enable 1 by 1 till you find the culprit.



If a problem when all 3rd party addons are disabled, contact helpdesk and let them sort it out (or they might know of an open issue).

[/quote]