Epdq Not Communicating With Site

Since updating our site to 4.3.6 we have been unable to get ePDQ working, it was working fine before the upgrade but now when you place an order you get transferred to the ePDQ gateway where the payment goes through fine but when you get transferred back to our site a message flashes up ' Important Transaction was canceled by the customer' and the order status is unchanged.

We have checked firewall etc and all is as it should be but we have noticed that the order number that ePDQ displays in the admin area seems to have the transaction time tagged on the end, for example what should display as orderID: 9555 actually shows as orderID:9555_15_46_01

This is different to the order number used in the CS Cart admin area so i wonder if this is the cause of our problems?

We also tried using a SagePay Form test account and we got a similar error, their technical support advised that the error was due to an invalid order ID being sent so could CS Cart somehow be sending the incorrect order ID number during the transaction process?

Many thanks in advance for any help or advice

Please contact CS-Cart support with this issue. It is required to examine it on your server


We had the same/similar issue and we contacted our host who made a couple of alterations to the firewall and all was/is good.


Thanks BarryH,

We have managed to get a SagePay test account working but we still get the same error with ePDQ,

CS-Cart support have told us that there is a problem with our SSL Certificate as they received the following error when they tried our connection:

60 : SSL certificate problem: self signed certificate in certificate chain

We have checked our SSL Cert in three different SSL checkers and all come back fine.

Going nowhere fast with this...