Email Sent From Root @localhost

Hi there,

We are facing issue that when a user first time sign's in with linkedin, then a email is sent from “Root user” i.e. root@localhost into his inbox

initially email's were not sent from the store when the user first time registers but we had reported this issue to cs-cart in bugtracking here and they had suggested a fix.

Is this a bug from there side

How should we fix it?

It's your php settings. Contact your host.

Could you elaborate more on the issue?

If you are using php mail, then the 'from' in the Envelope of the message is set in php.ini or via an ini_set() command. That is different from the From address in the message which can be specified via the parameters. But generally if you're seeing mail with a from line of the server (versus your domain) or root (versus a user within your account) then it's usually an incorrect php configuration. Just ask your host to ensure that php mail is setup to come from the email address you want (but it should be from your domain).

Hi tony,

Let us assume that their is an issue in the php.ini file, as you are suggesting. Then in that case, I believe all the emails related to our store should be sent from roo@localhost including the (order notifications, notification when vendor account is created/disabled).

But it seems that only the profile update email is being sent from the root@localhost

All other emails are being sent from the email address we had configured into the store admin settings

Don't you think it could be the result of the bug fix suggested by cs-cart support here

Best,

NaMo

I would guess (by your host and you can do some testing to verify) that the From address used by the account creation has an issue and it might be defaulting back to the basic php configuration.



I'm guessing. Your host can be more helpful by reviewing your mail logs on your server to see exactly what's going on.

Hi tony,

We had tried contacting Hostgator and they told us that everything is working fine. However we had moved our cs-cart setup from one folder to another. Could this be the reason for this issue?

Well we have fixed it

Care to share what you found and what you did?

Yes, well there had been a little mess around in our store settings.

We had somehow left the email address fields in some of the row's under the Company settings.

Thus, the email's were being sent from “root@localhost” as default

Oops! :-) So it was doing what you told it to do? I hate when that happens! Glad you found the problem.

Haha, yes. Sometimes, mess happens. Anyways thanks tony for taking out your time and answering the post. :)