Email Company Name and From Address Change

I would like to change the company name and email address for communicating with customers, ie order status updates. I have updated the company name and all my email addresses at the Administration > Settings > Company page, but there are no changes showing up in the actual email. I’ve logged out, cleared the cache and have grown frustrated a bit. Nothing I do seems to affect the email from company name and it’s corresponding email address.

I have made changes in the form builder, but that is only for the pages / contact us portion I believe. Eitherway, it had no resulting affect for the order status emails.

Am I missing a setting somewhere else within the Admin?

I can override this in the fn.common.php file, but I was wondering if there is a better way to do this?

Thanks for any advice.

FYI- Here is what I did to override my issue, which I can continue to use if needed.

$newFrom = “”;

$newCompany = “My New Company Name”;

if (!is_array($from)) {

// $__from[‘email’] = $from;

$__from[‘email’] = $newFrom;

// $__from[‘name’] = Registry::get(‘settings.Company.company_name’);

$__from[‘name’] = $newCompany;

} else {

$__from = $from;


The “From” value is set in a variety of places depending on what context you are in (news, users, orders, etc.)… In almost all instances, it uses Registry settings for things like “settings.Company.users_department” or "settings.Company.site_administrator’, etc.

To confirm, go to var/cache/ directory and search for the string ‘users_department’ in all the files (I’d be more specific but I use the PDO caching method so it doesn’t use files).

Look at the values and ensure they are what you expect. If not, remove the whole var/cache directory structure (it will be recreated when it needs it).

My bet is that you haven’t really cleared the cache. You do know that as of 2.0.15 you can only clear the cache from the admin area unless DEVELOPMENT is defined (which has other side effects).

I didn’t find a cached file with the string of users_department, but did find settings.cache.php and it contained all my old settings. So, you are correct, I didn’t really clear the cache. I believe my settings are correct now. Thank you.