Customer email for downloadable receives 403 error

Please for give me if I am putting this in the wrong area but this is the only forum area that I can post to. (I only have a trial key and unable to ask questions through the help desk)

I am setting up / testing CS-Cart, all has gone pretty much OK. I have live shipping- UPS, USPS, and FedEx, working along with Paypal and so on.

I am testing downloadable products, but one problem I am getting is in the customers email. The link in the email to the item / file the page returns a 403 error. The email also has two links and neither of them work (same 403 error page).

Here are the links from one of the emails, real name replaced with “sitename”:

PDF Test http://**/cscart/index.php?

PDF test (26 412 747 bytes)

To me the links look like there is extra stuff being added like - &

However if the customer logs in to their account and clicks the download link from there all goes well.

What am I overlooking?



I did a little digging and this is what I found.

The error came from the template file - edp_access.tpl - was adding “” to the link, so I edited the lines and the link to the download file worked while the link to the sample file did not. I’m not sure what went wrong with the link to the sample file, but then I figure “why would a customer want a link to the sample?” so I just removed that line and in the email that the customer receives only has the one link and that link works… :slight_smile:

Below is a paste of the lines of the original file:

```php {$oi.product}

{foreach from=$edp_data[$oi.product_id].files item="file" key="file_id"}
{$file.file_name} ({$file.file_size|number_format:0:'':' '} {$lang.bytes})


Below is what I changed it to:

```php {$file.file_name} ```

Location of the file edp_access.tpl is .../skins/austere/mail/orders/ so I am thinking also that maybe just an error with the Austere skin?

Thoughts, idea's coments???


Sorry about replying to my own post, but I am looking for some answers.

Since I am not an expert on coding, my question now, is this really a error in the html or did I set something up wrong? And then if I am not wrong about the template file, anyone else having this issue?

For me, the top link goes to :

so I removed the following:

Since the top link in the download email never worked, I’m not sure what the user would see (sample file?), so just having the title text of the eBook works great. The file name below with size link, works as before.

cntbill, thanks for the info on this fix, and no you didn’t do something wrong I seem to have had half the problem also.

huski - Thanks for your reply, it’s good to know that I am on the right track :wink:

Unfortunatly, none of these edits worked for me.

I posted here: