cs-cart not working

site appearance is terrible. I wonder what is the error? How to be corrected?



[url]http://www.bilimcell.com//[/url]

It looks like you have a path problem or your database information is wrong. Check your config.local.php file:



$config[‘db_host’] = ‘%DB_HOST%’;

$config[‘db_name’] = ‘%DB_NAME%’;

$config[‘db_user’] = ‘%DB_USER%’;

$config[‘db_password’] = ‘%DB_PASSWORD%’;

$config[‘db_type’] = ‘mysql’;



make sure the information you’ve entered is correct.

__________________

Do you have smartoptimizer installed?

Anyway, check for redirects on your .htaccess file, it may have errors, happened to me once

htaccess file contents are as follows





DirectoryIndex index.html index.php





RewriteEngine on

Some hostings require RewriteBase to be uncommented

Example:

Your store url is [url]http://www.yourcompany.com/store/cart[/url]

So “RewriteBase” should be:

RewriteBase /store/cart

RewriteBase /

RewriteCond %{REQUEST_FILENAME} !.(png|gif|ico|swf|jpe?g|js|css)$

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule . index.php?sef_rewrite=1 [L,QSA]



Your url has 2 // after it. Maybe that’s the problem if it’s the way you have it entered in your config.local.php.



Check your config.local.php file around line #58. It should look like this:



// Host and directory where software is installed on no-secure server

$config[‘http_host’] = ‘www.bilimcell.com’;

$config[‘http_path’] = ‘’;



// Host and directory where software is installed on secure server

$config[‘https_host’] = ‘www.bilimcell.com’;

$config[‘https_path’] = ‘’;

[quote name=‘ufukinan’]site appearance is terrible. I wonder what is the error? How to be corrected?



[URL]http://www.bilimcell.com//[/URL][/quote]

It seems to be a php configuration problem.



[url]https://www.cs-cart.com/requirements.html[/url]

The path information is incorrect and an additional slash is being added to it

[QUOTE]












[/QUOTE]

ufukinan, open config.local.php and change the path variables to this below
```php // Host and directory where software is installed on no-secure server
$config['http_host'] = 'www.bilimcell.com';
$config['http_path'] = '';

// Host and directory where software is installed on secure server
$config['https_host'] = 'www.bilimcell.com';
$config['https_path'] = ''; ```

[COLOR="Red"]EDIT:
You will also need to clear your site cache as well to reflect the change

/var/cache and /var/compiled/*

Most servers will allow you to just delete these directories and they will then be recreated[/COLOR]

Thank you for your help. How do I fix the path? tried but failed too.


[quote name=‘S-Combs’]The path information is incorrect and an additional slash is being added to it





ufukinan, open config.local.php and change the path variables to this below

```php // Host and directory where software is installed on no-secure server

$config[‘http_host’] = ‘www.bilimcell.com’;

$config[‘http_path’] = ‘’;



// Host and directory where software is installed on secure server

$config[‘https_host’] = ‘www.bilimcell.com’;

$config[‘https_path’] = ‘’; ```



[COLOR=“Red”]EDIT:

You will also need to clear your site cache as well to reflect the change



/var/cache and /var/compiled/*



Most servers will allow you to just delete these directories and they will then be recreated[/COLOR][/QUOTE]

Be sure to clear your stores cache and compiled directories after making the path change so it will then load fresh files

i think it is a smaroptimizer problem. (if you have installed it of course)

If yes, the open smartoptimizer/config.php and change the …base_dir… to something>save>clear cache>then change …base_dir… back to “…/”

or try to change the cache dir to “/”

Thank you to all of you. The problem stems from the file permissions. settings hosting company. I changed the hosting company did not issue.