CS-Cart 3.0x Admin Not Found after new addon fail

Not sure what has happened but after testing a newly created addon on version 3.0x something has failed. The admin is now not found, but store is still up and running. Any ideas what may have caused this fail or how to gain access to admin?

Already tried restarting PHP and manually deleted all caches.

Ok just discovered it is not actually 404 Not Found, but admin is failing/crashing and the error interception is presenting 404 Not Found page.

If the worse comes to worse then I will backup/save addon changes and re-install.

I had a similar problem with an addon developed by CS-Cart for 2.2.4, which I tried to install on 3.0.3 just to see if it would work or not. It didn't, it just made the admin pages give me the 'Redirection' error in Firefox (as if the page is redirecting to a redirected redirect and confusing the browser). I had to do the following to disable the addon to get back into the admin.

Edit the database table to disable the add-on, cscart_addons table - set 'Status' value to 'D'. Might need to then run a Repair on the database table afterwards, sometimes I've found editing the database directly makes the admin control panel act oddly for some reason or other. Probably have to manually clear your cache too.

Good luck!

Thanks for the reply I removed all related info from database for this addon, but also had to do delete var/cache/registry

Looks like something went wrong with the addon install which left something corrupted in var/cache/registry

This is a new addon for 3.0x I think something went wrong which I am looking into.