"continue" Between Https And Http Pages

For some reason, when you leave a HTTPS page to go to a HTTP page - we get a blank white page in the middle without continue in the top left hand corner. See below

How do I stop this?

We just started getting this a few days ago. We need to resolve it immediately. Any ideas???

Go to Settings>Security Settings and check: “Keep HTTPS connection once a secure page is visited.” That way no one will be going from a HTTPS page to a HTTP page.

Thank you! :)